WordPress.org

Ready to get started?Download WordPress

Forums

My head tag keeps closing before it should (2 posts)

  1. glimaleite
    Member
    Posted 3 years ago #

    The website is http://www.cafenapolitica.com/

    For some reason the head ends before it should and that results in serious issues in IE, since the links and everything goes to the body tag.

    Here is my header.php code

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    
    <head profile="http://gmpg.org/xfn/11">
    
    	<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    
    	<?php if (is_search()) { ?>
    	   <meta name="robots" content="noindex, nofollow" />
    	<?php } ?>
    
    	<title>
    		   <?php
    			  if (function_exists('is_tag') && is_tag()) {
    				 single_tag_title("Tag Archive for ""); echo '" - '; }
    			  elseif (is_archive()) {
    				 wp_title(''); echo ' Archive - '; }
    			  elseif (is_search()) {
    				 echo 'Search for "'.wp_specialchars($s).'" - '; }
    			  elseif (!(is_404()) && (is_single()) || (is_page())) {
    				 wp_title(''); echo ' - '; }
    			  elseif (is_404()) {
    				 echo 'Not Found - '; }
    			  if (is_home()) {
    				 bloginfo('name'); echo ' - '; bloginfo('description'); }
    			  else {
    				  bloginfo('name'); }
    			  if ($paged>1) {
    				 echo ' - page '. $paged; }
    		   ?>
    	</title>
    
    	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
    
    	<link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" />
    		<meta http-equiv="Content-Type" content="text/html;charset=UTF-8"/>
    		<meta name="robots" content="index,follow" />
    		<meta name="classification" content="Jornalismo Político" /> <!-- Classificação //-->
    		<meta name="language" content="pt-br" />
    		<meta name="title" content="Café na Política" /> <!-- Título //-->
    		<meta name="author" content="Desenvolvido por: GabrielLeite.com.br" />
    		<meta name="copyright" content="Café na Política - Todos os Direitos Reservados" /> <!-- Copyright //-->
    		<link rel="shortcut icon" href="favicon.ico">
    		<meta http-equiv="content-type" content="text/html; charset=utf-8" />
    	<!--META DADOS fim //-->
    		<!-- css //-->
    		<link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    		<link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/css/reset.css" />
    		<link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/css/text.css" />
    		<link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/css/960.css" />
    		<link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/css/layout.css" />
    		<!-- css //-->
    <?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>
    
    <?php wp_head(); ?>
    
    </head>
    
    <body>
    <div id="bgCafe" class="clearfix">
    
    	<div class="container_12"><!-- container //-->
    		<div id="topo" class="grid_12 alpha">
    
    			<div id="logo" class="grid_8 alpha">
    				<a href="<?php bloginfo('url'); ?>" title="Café Na Política" ><img src="<?php bloginfo('template_url'); ?>/images/logo.png" alt="Café na Política" /></a>
    			</div>
    
    		</div>
    
    		<div id="conteudo" class="grid_12 alpha omega"><!-- conteudo //-->
    
    			<div  id="inicioConteudo" class="grid_12">
    				<a href="http://www.cafenapolitica.com/wordpress/?page_id=2" title="Intype" target="_self"><img src="<?php bloginfo('template_url'); ?>/images/sobreOBlog.png" alt="testing" /></a>
    			</div>

    Anything else I should put in here to help you help me?

    Thank you very much for your attention!

  2. glimaleite
    Member
    Posted 3 years ago #

    More useful information, for some reason when loading the archive.php thru clicking one of those categories listed, the head works fine. But when in single.php or index.php its broken.

Topic Closed

This topic has been closed to new replies.

About this Topic