WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] My fix for: Ajax problem / Spinning Circle at checkout (5 posts)

  1. llon
    Member
    Posted 10 months ago #

    Hi all,

    I've struggled for weeks with the 'spinning circle' at checkout with all browsers.

    I tried all the usual 'fixes' mentioned about IE9 compatibility, uninstall conflicting plugins, jQuery probs, disable https, make the url the same in both boxes of WP settings, increase memory limit, check it when logged in/out...NONE OF THESE WORKED (for me).

    As standard I install WordPress and then follow the hardening guide. For me this was the problem, WooCommerce requires access to /wp-admin/ at checkout for some of the AJAX code to work for the checkout form/calcs at the bottom.

    The fix: Make sure you do not have any blocks to /wp-admin/ in .htaccess, httpd.conf files or in the web server config anywhere. Allow all public access to /wp-admin/ and then retest, this immediately fixed it for me.

    Hope this helps some people

    Thanks

    Neil [sig moderated as per the Forum Rules]

    http://wordpress.org/plugins/woocommerce/

  2. llon
    Member
    Posted 10 months ago #

    As this is for information only I'll mark it as resolved myself.

    Thanks

    Neil [sig moderated as per the Forum Rules]

  3. Roy Ho
    Member
    Posted 10 months ago #

    To add to your findings, many plugins and themes uses the same URL for accessing AJAX and it is the proper way to access AJAX in WP so this is not particular to WooCommerce plugin.

  4. llon
    Member
    Posted 10 months ago #

    Thanks, yes you're correct and it does mention it in the WP Hardening guide. But often people (myself included this time :) don't think about the future implications.

    Thought I'd post as this 'woocommerce spinning circle' seems very widely reported. One more thing to check/fix hopefully helps!

    Cheers

  5. Ultimate Peter
    Member
    Posted 3 months ago #

    Hello, I just researched this problem for two days and am trying to pass on my solution, because it was super frustrating:

    After entering City, State, Zip: Ajax spinner would spin indefinitely, even with no payment gateways, only cheque!
    Only for people not logged in to site. Worked fine for me logged in.
    Also, cart widget wouldn't display products.

    I followed every piece of advice I could find and the following didn't work:
    -Disable all plugins except woocommerce. (including fedex and payment gateway)
    -Disabled Ajax add button
    -Tried other themes, same thing
    -Checked all page names, shortcodes, and made sure they were appropriate parent/child.
    -Increased memory to WP and PHP to 128mb.
    -I didn't un-force https at checkout... Um, because that's crazy.
    -Turned off all shipping and tax.
    -Made sure my Site URL and Home URL were matching on the WP General Settings.

    So... MY BIG FIX WAS:
    I had WP All-in-one Security plugin installed...
    Now, even though I had it disabled:
    It had left behind some code in my .htaccess file.
    I don't know how I even came across it (while I was looking for some other config file I think). So, I got rid of the code in there for some of the security stuff and it worked again!

    Later,
    Peter
    http://qbservices.net

Reply

You must log in to post.

About this Plugin

About this Topic