WordPress.org

Ready to get started?Download WordPress

Forums

Related Posts
[resolved] My featured image is not showing on related post (15 posts)

  1. christyfm
    Member
    Posted 9 months ago #

    My post image is not showing on the related post. Each post has one image and it is in the post and it is the featured image. The images displayed are not in my media library.

    My site is http://www.fujidreams.com.
    The posts are under the menu item "Blog"

    I have combed the other posts on this forum but I can't figure out what I'm doing wrong.

    http://wordpress.org/plugins/related-posts/

  2. silvoslaf
    Member
    Plugin Author

    Posted 9 months ago #

    Hey Christy, thanks for reaching out & please accept my apologies for not responding any sooner!

    As for your problem — I took a look at your blog and can indeed find that the images are not being extracted correctly. But you mentioned that the images you have there as inserted in your blog posts are actually not in your media gallery — are they linked from somewhere else? If so, from where exactly and via which plugin/service?

    Let me know what's going on with your images and I'll do my best to help you out!

    Take care & I'm looking forward to your reply! (And I won't keep you waiting any more!)

    Best,
    Silvo

  3. rlwinkel
    Member
    Posted 8 months ago #

    Hi
    My posts are not showing related images either...

    Images are in my media library. Only a few posts have images right now, but the default image isn't showing either.

    Richard
    http://www.exceedingthedrift.com

  4. silvoslaf
    Member
    Plugin Author

    Posted 8 months ago #

    Hey Richard, thanks for the follow up, I'll gladly help!

    I've checked your blog and saw that most of your blogposts don't have any images at all, as well as that your related posts are missing their thumbnails all together.

    Did you activate the thumbnails for your related posts in your plugin settings? You can find it in your plugin settings, under the 'Customize' drop-down menu, next to the box called "Display Thumbnails For Related Posts".

    See my screenshot for easier navigation: http://cl.ly/image/2x0P3Y1i2u1T

    Could this be the case why your thumbnails are missing? Let me know, I'm eager to help!

    Take care & I'm looking forward to your reply!

    Best,
    Silvo

  5. rlwinkel
    Member
    Posted 8 months ago #

    Hi
    That was it... missing the display thumbnails for related posts

    Only partially related, do you know of a good online source for generic thumbnails. I don't always have the right image in my library for the post and I don't really like hunting to find one.

    Thanks
    Richard
    <><

  6. silvoslaf
    Member
    Plugin Author

    Posted 8 months ago #

    Hey Richard, sure thing, try the 'Editorial Assistant by Zemanta' plugin, it offers you related, copyright cleared images as you type, which you can easily insert in your freshly composed posts (or older ones, doesn't matter).

    Here's the demo version of it, if you wish to play it first, before installing it: http://www.zemanta.com/demo/

    And here's the link to the plugin itself: http://wordpress.org/plugins/zemanta/

    But please note, that you'll have to un-tick the box next to "Display Related Content (Articles) on Compose Screen" option first, in your current plugin ('Related Posts' plugin), before installing this new one ('Editorial Assistant by Zemanta'), in order to avoid any widget display errors.

    Either way, do let me know how it goes or if you have any more questions what-so-ever, since I'll gladly help!

    Take care & have a nice day!

    Best,
    Silvo

  7. christyfm
    Member
    Posted 8 months ago #

    Hi Silvo,
    Thanks for getting back to me. When I said the images are not in my media gallery, I was trying to say that I have no idea where they are coming from. I did not upload and I do not recognize them.
    Thanks,
    Christy

  8. Mateja
    Member
    Plugin Author

    Posted 8 months ago #

    Hi Christy,

    you are probably seeing default thumbnails for some posts. Our plugin creates thumbnails for posts from images in them. If it can't find an image in the post or if this image is too small, it returns default abstract image.

    Let me know if this is the case.

    Cheers,
    Mateja

  9. christyfm
    Member
    Posted 8 months ago #

    Hi Mateja,
    I understand that this plugin looks for an image in the post or the featured image. In both cases, the image is the only one in the post and it is also set as the featured image. Here are links to the posts where I am using the plugin:

    http://www.fujidreams.com/planning-blog/

    http://www.fujidreams.com/how-much-will-airfare-cost/

    You also mentioned size. One of the images is 220 x 223 and the other is 336 x 335. Are these too small? If so, what size do they need to be?

    Thanks, Christy

  10. Mateja
    Member
    Plugin Author

    Posted 8 months ago #

    Hey Christy,

    thanks for the links. Unfortunately, I was not able to reproduce the missing thumbnail issue.
    I downloaded your GIF images and used them both on our test blog with latest version of WordPress (3.8). Thumbnails were generated correctly no matter whether I inserted the images into a post or used them as featured image or both. Image size is not the problem in this case.

    I've noticed you're using WP Super Caching plugin. Maybe both posts were cached before thumbnails were generated and they didn't replace the static images in time. Try to disable the WP Super Caching plugin and refresh the posts to see whether they'll get new thumbnails.

    Please let me know if this works.

    Cheers,
    Mateja

  11. Mateja
    Member
    Plugin Author

    Posted 8 months ago #

    Christy, just a quick update...

    I installed WP Super Cache and tested it with our plugin. With caching turned on there was an issue: old thumbnails appeared for the posts with new featured images (or different images in the post). Maybe you're experiencing something similar on your blog.

    If disabling the WP Super Cache plugin or only turning the caching off won't be enough, try to remove the featured image and add it back again for both posts.

    Best,
    Mateja

  12. christyfm
    Member
    Posted 8 months ago #

    Hey Mateja,
    Sadly, disabling WP Super Cache did not make a difference. I removed the images, emptied the cache and replaced the images. The same thumbnails remain. They do not change. I even tried deactivating Related Posts, emptying the cache, and activating it again. I still get those same thumbnail images that I don't recognize.

    Do you have any other ideas?
    Thanks, Christy

  13. Mateja
    Member
    Plugin Author

    Posted 8 months ago #

    Christy,

    there is one more thing to try: create a new blog post with a new large enough image but not in GIF format. Publish the post, open an existing post that has the new post shown as related post at the bottom and check whether you see proper thumbnail and not the default one.

    If this won't work and if you're willing to share blog's credentials with me, please write an email to support AT zemanta.com, so I can take a look at the settings and maybe figure out what's going on.

    Best,
    Mateja

  14. christyfm
    Member
    Posted 8 months ago #

    Mateja,
    Good News! Changing to jpg images works. When I created a test post using a jpg image, the related post thumbnail for the test post displayed the correct image.

    Then I deleted my existing posts and re-posted them with jpg's instead of gif's. Now the related post thumbnail images are all correct!

    Thank you for your help and for not giving up on me, Christy

  15. Mateja
    Member
    Plugin Author

    Posted 8 months ago #

    Great news! :)
    I'm glad this worked, otherwise we would have to do some voodoo magic. Giving up was not an option.

    Take care & have a nice holiday,
    Mateja

Reply

You must log in to post.

About this Plugin

About this Topic