WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] My Blog page does not work (43 posts)

  1. jeffstamer
    Member
    Posted 1 year ago #

    Hi all,
    Here's my issue:
    When I go to my website (http://www.firefallphotography.com/home-page/) and click on the 'blog' tab. Nothing happens for a long time, then I get an error message that says "Page can not be displayed".
    However, I can get to my posts on the web if I use their specific name (for example:
    http://www.firefallphotography.com/hummingbird-heaven/

    So I know my posts are out there, but something is wrong with my 'blog' page.

    I've already searched the forum but none of the solutions offered have helped.

    I am photographer, not a web designer, so if you can use small, non-technical words and talk to me like I was a five year old, it will probably help:)
    Thanks!
    Jeff

  2. Joni
    Member
    Posted 1 year ago #

    Hi, Jeff. The slug (Pretty URL name for your page or post) for your blog page seems to be /blog-3. This suggests that you've been creating a few pages named "Blog", at least three of them. So WordPress names them with successive numbers; e.g., /blog, /blog-2, /blog-3, etc.

    Go to your Pages listing and see if you can find the page "/blog-3
    -- you should hover your mouse over the "View" link and watch your browser's status bar (usually lower left corner). You should then be able to locate that page. If not, it doesn't exist and you need to find the real blog page and then plug that into your top nav menu. Right now it's pointing to blog-3, which may or may not exist.

    HTH

  3. jeffstamer
    Member
    Posted 1 year ago #

    Hi Joni,
    First of all, thanks so much for your help!
    I followed your instructions and my current blog page is /blog-4. So that might be the problem.

    Now, pardon my ignorance, but where to I find the 'top nav menu?' and how would I change it so it has 'blog-4 instead of blog-3.

    Thanks again!
    Jeff

  4. Joni
    Member
    Posted 1 year ago #

    Should be under Appearance > Menu

  5. jeffstamer
    Member
    Posted 1 year ago #

    Hi Joni,
    I went to Appearance > Menu and deleted the blog page (blog-3) that was there. I then added a new blog page. I right clicked and confirmed that the new blog page was 'blog-4'. However, when I click on my website: http://www.firefallphotography.com/home-page/
    and then click on the 'blog' tab, I still get the 'page cannot be displayed' error message.

    What would you suggest next?
    Thanks!
    Jeff

  6. Joni
    Member
    Posted 1 year ago #

    Are you SURE you are linking to the correct blog page? There can be no other explanation than that it is still pointing to the wrong page. Have you cleared out your browser cache?

    Oh, and this may sound silly, but I've done it a few times. Did you make sure to hit the big blue SAVE button at the right top and right bottom of the menu panel once you were done adding and configuring your menu structure?

  7. jeffstamer
    Member
    Posted 1 year ago #

    Hi Joni,
    1) No, honestly I'm not sure I'm linking to the right blog page...how do I know for sure?
    2)I cleared my cache on IE 10 again when I got your last note, but no change on the blog page
    3) Not silly...I've done it my self. I double checked and hit the SAVE button again...but still no luck.

    Let me know how be sure about linking to the correct blog page and I'll give it a shot.

    Thanks!
    Jeff

  8. Joni
    Member
    Posted 1 year ago #

    Well, I see you seem to have several versions of every page. The "About" tab links to /about-3 and so forth. To simplify your life, offload those other versions to your computer in a text file or something. That way you only have ONE About and ONE Blog page and you know those are the correct ones!

  9. jeffstamer
    Member
    Posted 1 year ago #

    Hi Joni,
    You are correct, I did have multiple old versions in my trash file. I went ahead and deleted them. Now I only have a single version of each page, including 'blog' 'about' and 'home.'

    However, I still have that problem with my 'blog' page...you click on it and it thinks for a long time and finally comes back and says This page can't be displayed.

    What can we try next?
    Thanks for all your help!
    Jeff

  10. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    A quick look show your home page 404. Review this, http://codex.wordpress.org/Creating_a_Static_Front_Page

  11. jeffstamer
    Member
    Posted 1 year ago #

    Hi Kmessinger,
    I reviewed the link you sent me.
    I did have my Front page displays set up as instructed (I selected STATIC PAGE and have Front' Page set up as 'Home' and Posts page set up as 'Blog.'

    However, I do not understand the last part of the instructions in the link when it says: 'Enable "Permalinks" to show the "page title" in the address, since /index.php?p=423 defeats the purpose of making a static front page.'

    I looked under Settings>Permalinks but didn't see anything about "page title" there.

    What should I try next?
    Thanks!
    Jeff

  12. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Set your permalink choice to show a page name like, post name or day and name or month and name instead of the default.

  13. jeffstamer
    Member
    Posted 1 year ago #

    Under Settings>Permalinks>Common Settings, I have the fifth option selected (Post Name). I don't have the default selected.

  14. jeffstamer
    Member
    Posted 1 year ago #

    Hi All,
    Looks like my permalinks are set correctly, but I still can't access my blog. So we must have a different problem?

    I am open to all suggestions,
    Thanks!
    Jeff

  15. Joni
    Member
    Posted 1 year ago #

    First of all, your home page should be at http://www.firefallphotography.com/ or http://www.firefallphotography.com/home-page/ ... right now it's rolling over to http://www.firefallphotography.com/-1 which is WEIRD.

    I hate to ask you to switch to the default theme because you may lose some of your current theme settings depending on how convoluted the theme is.

    I am also wondering if your .htaccess file isn't somehow jacked up. Those are my only two ideas.

  16. Joni
    Member
    Posted 1 year ago #

    I don't think switching themes is going to help with the navigation issue. So don't even go there. :)

  17. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    When trying to access the "blog" page, http://www.firefallphotography.com/blog-4 it rolls over to http://www.firefallphotography.com/blog-3-2
    and the error message, The webpage at http://www.firefallphotography.com/blog-3-2/ has resulted in too many redirects.

    Please post your htaccess file. I think Joni is right.

    BTW, disabling "right click" will not save anything from being copied and why are you telling IE to run as IE9?

  18. jeffstamer
    Member
    Posted 1 year ago #

    Hi Guys,
    Forgive my ignorance, but what do you mean by "post your htaccess file"?

    Disabling the right click is a feature of the Photocrati theme I use. If you think it is causing any issues let me know and I will turn it off.

    I wasn't aware that I was telling IE to run as IE9..in fact, I have no idea how I would do that if I wanted to:)

    Thanks!
    Jeff

  19. Joni
    Member
    Posted 1 year ago #

    Jeff it looks like you still have a bunch of different pages all with similar names. The same names, actually, but WP deals with that by tacking on a sequential number to each. That is, I believe, why you are seeing page slugs like blog-3-2. If I were you, I'd go to that menu and delete everything but the Home page, and then start rebuilding your page menu from scratch.

    And yes, posting the .htaccess file would help, but you need to go into your web host's File Manager in order to do that unless you have a plugin installed. OR download it to your hard drive via FTP and then copy and paste it here.

  20. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    http://codex.wordpress.org/Using_Permalinks#Where.27s_my_.htaccess_file.3F

    Your theme is a premium theme meaning you paid for support when you purchased the theme. Support for your theme is at, http://members.photocrati.com/

    Premium themes are not supported in this forum. But someone can help if they want to . . .

  21. jeffstamer
    Member
    Posted 1 year ago #

    Joni,
    My host is Bluehost. I opened the cPanel and found File Manager, but I didn't see anything called .htacess file. Would it be listed under something else?

    I've got 25 pages many of them with unique photo galleries attached to them that would be lost if I deleted the page...it would be an incredible amount of work to recreate them. If you think this is the only way to fix it, I will delete them, but if there is another way, I'd love to try it! I double checked my menu again and there are no duplicates of any pages.

    Kmessinger,
    So you think the problem isn't wordpress but it is an issue with my theme?

  22. Joni
    Member
    Posted 1 year ago #

    You aren't deleting anything. Look for the .htacces file, you may have to tell the file manager to show all files including .dot files. It is a text file so you should be able to view or edit it in your BlueHost file manager app and copy and paste its contents here, making sure to use the backticks, which is the lowercase tilde key to the left of the 1/! on a U.S. keyboard.

    HTH

  23. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    No, I am saying premium themes are not supported here. They can effect the way wordpress works both backend and frontend and since we don't have access to them can't be much help.

    Joni (may I speak for you?) suggested deleting the menu not the pages themselves.

  24. jeffstamer
    Member
    Posted 1 year ago #

    Hi Joni,
    Thanks! I did have to tell it to show .dot files! Okay, so I opened the file up and copied it below.I put a backtick at the start and the end. Let me know if this is okay!
    Jeff

    .htaccess
    ASCII text

    # Use PHP5 Single php.ini as default
    AddHandler application/x-httpd-php5s .php
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  25. Joni
    Member
    Posted 1 year ago #

    Yes, that is what I was saying. Delete the nav menu items and start over. That just deletes what APPEARS on the nav menu. It does NOT delete the pages themselves.

    And depending on how the theme was crafted, it can affect WordPress's behavior -- and the behavior of plugins -- in a negative way. That was why I originally thought of disabling that theme, but then thought better of it due to the havoc that would wreak, plus I just don't think it's a theme issue somehow. I think it's got to do with the cruft that's been generated with all the pages being created and the fiddling around with permalinks. :)))

  26. jeffstamer
    Member
    Posted 1 year ago #

    Ok..so you are saying that I go to Appearance>Menu and on the right side of the screen, remove everything listed on the Menu. Then I go over to the left side of the screen where all the pages are listed, click the box in front of all of them and re-add them to the menu...right?

    Jeff

  27. Joni
    Member
    Posted 1 year ago #

    I would be selective. Be sure you want the page on the menu. I think you have more than one of a few pages so you shouldnt want ALL your About or ALL your blog pages there. Find out which ones you want live and which ones you don't On the ones you don't mark them PRIVATE or DRAFT.

  28. Joni
    Member
    Posted 1 year ago #

    And you have too many instances of the same directives in your .htaccess file and I think that is confusing WordPress.

  29. jeffstamer
    Member
    Posted 1 year ago #

    Hi Joni,
    Just to be clear, I only have one About page and one Blog page. I deleted the duplicate About and Blog pages yesterday. In other words, if you go to Pages>All pages and look down the list, there is only a single page called 'blog' (or anything like blog) and a single page called 'home.'

    I'm going to delete the blog and home page from my menu now and then add them back and see what happens.

    Thanks again for sticking with me thru this!
    Jeff

  30. jeffstamer
    Member
    Posted 1 year ago #

    Joni,
    I just removed the home and blog page from the menu. I then saved the menu and opened the website. As expected, the tabs for home and blog no longer were there.
    I then re-added the 'home' and 'blog' pages to the menu. Unfortunately, when I opened the website, it looked just like it did before I removed and re-added them to the menu.

    Thoughts?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags