WordPress.org

Ready to get started?Download WordPress

Forums

My blog is broken (16 posts)

  1. betaphi
    Member
    Posted 2 years ago #

    Don't get too technical or I won't understand. I'm a senior with a simple blog for six years, but now my blog is broken. All of the buttons I use to indicate bold, italic, lists, inserts, etc. are gone, and the photo uploader doesn't work. Anything you can do to help restore my blog would be appreciated.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. Peter_L
    Member
    Posted 2 years ago #

    Did you update recently?

  4. betaphi
    Member
    Posted 2 years ago #

    Not sure what you mean by 'update', Peter. If you mean a version of WordPress, I don't know what version I have now nor how to update to a newer version. I don't know what a plugin is either or where to find one.

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    What is the url of your site?

  6. Peter_L
    Member
    Posted 2 years ago #

    Hmm, ok. If you don't know what it is, it's probably not the problem.

    So, specific to the problem: you are talking about the text editor, right? When you write a new page or post, the box where you put your main text, you can't see the word-like buttons anymore?

    If so, try clicking on that same box, top right, you should see 2 tabs:
    html - wysiwyg
    Click the wysiwyg tab.
    If nothing happens, try specifying the problem some more.
    F.e. is the problem in the dashboard or on the site itself?

  7. betaphi
    Member
    Posted 2 years ago #

    url is betaphilings.com

    Peter, not sure what text editor is, but you're right that I can't see the word-like buttons anymore. Photo uploader doesn't work either.

    The problem is on the site itself. If I click 'Write' from the dashboard, I get this:

    Title (and a box below to type into)

    Post (with two words in boxes -- Visual and Code -- and below those a box to type into)

    Plain text is all I'm able to put in the big box. Clicking on either Visual or Code changes nothing. I looked at prior published posts and found that the html code showed in both boxes, ie, the Visual box is not working.

    No luck finding the wysiwyg tab you referred to, but feeling lucky to have you two trying to help me.

  8. Peter_L
    Member
    Posted 2 years ago #

    Do you know how to clear the cache of your browser? It's when you clear out your history and old coockies. It's when you have to fill in all your old passwords again.

    That might work.

    It's probably nothing serious on your site, but very hard to determine where the problem lies.

  9. esmi
    Forum Moderator
    Posted 2 years ago #

    Oh my goodness - you're using WordPress 2.2!

  10. betaphi
    Member
    Posted 2 years ago #

    esmi, is 2.2 the problem? I haven't had a problem with my site in several years, and as for updating to a newer version, can you direct me to a link or some place that shows how to update? Is Twenty Eleven the name of a theme that you're recommending? I'm so techno challenged. :/ thanks

  11. esmi
    Forum Moderator
    Posted 2 years ago #

    is 2.2 the problem

    Well, you're not going to find many (if any) themes or plugins you can use on the site. And upgrading the site is not going to be a simple process. See Upgrading_WordPress_Extended.

    Have you been editing the default theme?

  12. betaphi
    Member
    Posted 2 years ago #

    I know I'm still using the old default theme, but I don't know what you mean by 'editing the default theme'. Can you say more?

  13. Peter_L
    Member
    Posted 2 years ago #

    I don't think we'll be able to solve this problem.
    You don't have the skills to describe the problem + it's an old version of WordPress you're using. That means the problem you're having will probably be an older problem.

    Honestly, I'm a bit surprised this is the first problem you ran into.

    As for a solution: find a tech man that knows WordPress in your area and ask him to take a look at your problem.
    One tip: before you let anyone touch your site, make sure to have a database backup taken. Let this be your first focus! Backup your database.

    (This means that all the content you posted thus far, will be saved. It might be possible that your site crashes completely but with your backup, you'll get it running again.)

  14. esmi
    Forum Moderator
    Posted 2 years ago #

    Can you say more?

    Have you changed anything in your theme's files? Colors? Layout?

  15. betaphi
    Member
    Posted 2 years ago #

    no, esmi, I have changed nothing on the theme lately.

    "You don't have the skills to describe the problem"

    In my defense, Peter, someone with a masters degree in English is capable of adequate description. What you meant, I'm sure, is that I don't have enough familiarity with the terms and jargon of this field, and that is true.

    Thank you both for trying to help me.

  16. esmi
    Forum Moderator
    Posted 2 years ago #

    How comfortable are you using FTP or whatever file management application your host provides?

Topic Closed

This topic has been closed to new replies.

About this Topic