WordPress.org

Ready to get started?Download WordPress

Forums

My Blog Dissapeared, please help (3 posts)

  1. custerc
    Member
    Posted 7 years ago #

    So suddenly my blog has dissapeared and is replaced by the following error message:

    "Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at mysql. This could mean your host's database server is down."

    I get the same message when I try to load my wp-admin login page. My host server is fine, becuase a non-wordpress website I'm running on the same server works fine. I don't know when it happened, because I'm in China so I only get access to the internet occasionally, but it was working fine the last time I was online and now I just get this. WP also seems to have deleted my account (or something) becuase when I used my username to log onto this forum, it told me the username was still unregistered. So I re-registered it and posted this.

    If anyone can help, I'd much appreciate it. I'm in China, so this is the only way I can keep in touch with people at home. (Note: it isn't just down in China either, it's also down in the US). I also have very limited time to troubleshoot, which is why I set everything up BEFORE I left. I'm not sure why it sudddenly decided to stop working, but I very much wish it would start again.

  2. iscifi
    Member
    Posted 7 years ago #

    that is an error on the webhost! your webserver cant connect to the wordpress database using mysql, so contact your webhost.

    A regular website doesn't need a database, but wordpress does.

    It has nothing to do with where you are US or China, its the webserver that you blog is on not being able to connect to the database.

    Contact your webhost.

    Also take note: this forum is NOT your blog and does NOT control anything related to your website blog..

  3. custerc
    Member
    Posted 7 years ago #

    ok....i sent them an email, thanks....but why would it just suddenly stop working like that?

Topic Closed

This topic has been closed to new replies.

About this Topic