WordPress.org

Ready to get started?Download WordPress

Forums

muwp installation error.. (5 posts)

  1. lse12
    Member
    Posted 9 years ago #

    I want to install muwp(multiuser wordpress).
    in the step 2
    I have met this problem...error.
    error message is so long. I pasted just one of the error message lines.
    ----------------------
    WordPress database error: [You have an error in your SQL syntax near '/mwp_categories ( cat_ID int(4) NOT NULL auto_increment, cat_name varchar(55' at line 1]
    CREATE TABLE wp_/mwp_categories ( cat_ID int(4) NOT NULL auto_increment, cat_name varchar(55) NOT NULL default '', category_nicename varchar(200) NOT NULL default '', category_description text NOT NULL, category_parent int(4) NOT NULL default '0', PRIMARY KEY (cat_ID), UNIQUE KEY cat_name (cat_name), KEY category_nicename (category_nicename) )

  2. Anonymous
    Unregistered
    Posted 9 years ago #

    I've received this error as well. I'm using mysql 3.23.58, apache 1.3.33, and php 4.1.
    I don't have connection errors, just dozens of mysql errors, the first of which is:
    WordPress database error: [You have an error in your SQL syntax near '-inst_categories ( cat_ID int(4) NOT NULL auto_increment, cat_name varchar(5' at line 1]
    CREATE TABLE wp_wp-inst_categories ( cat_ID int(4) NOT NULL auto_increment, cat_name varchar(55) NOT NULL default '', category_nicename varchar(200) NOT NULL default '', category_description text NOT NULL, category_parent int(4) NOT NULL default '0', PRIMARY KEY (cat_ID), UNIQUE KEY cat_name (cat_name), KEY category_nicename (category_nicename) )
    and the last of which is:
    WordPress database error: [You have an error in your SQL syntax near '-inst_comments SET comment_type='pingback', comment_content = REPLACE(comment_co' at line 1]
    UPDATE wp_wp-inst_comments SET comment_type='pingback', comment_content = REPLACE(comment_content, '', '') WHERE comment_content LIKE '%'

  3. rikardon
    Member
    Posted 9 years ago #

    I'm having the exact same problem. Has anyone found a solution to this yet?

  4. Lagmeister
    Member
    Posted 9 years ago #

    I had the problem and had to change the table prefix in wp-settings - for some reason it was picking up a backslash (could magic quotes be turned on here?) that was blowing up the table create script.

  5. Donncha O Caoimh
    Member
    Posted 9 years ago #

    You're not installing it correctly - if "wp-inst" is in the url you're calling during the install replace it with "main". It doesn't exist in the filesystem but mod_rewrite will handle the request correctly if it's installed. You shouldn't need to change any table prefix.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.