WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Mutli problems with multisite (10 posts)

  1. chisao101
    Member
    Posted 1 year ago #

    Ok, I'm going to be as detailed as I can here so that any questions you might have for me will already be answered...to try and speed things up.

    I recently registered a domain (http://gnawlidge.com). I have a subscription to Lynda.com, so I went through the instructions to install WordPress and configure a multisite. I have installed WordPress many times, so that part was easy. The multisite setup, I followed step by step along with the videos. I checked with Godaddy, which is where I have hosting (for now) and they do not support the subdomain multisite if you use a shared hosting account. I believe what they mean is if I have more than one domain on the hosting plan, which I do. There are 3 total.

    So, I followed the instructions on setting up multisite exactly as they were told to me in the videos, and I worked right along with them the whole time. I have not yet added any other sites to it, I just went through the setup.
    Everything looked great until I tried to click on the Hello world blog post. I got a 404 error. I played around for a bit and found that if I set my permalinks to default, it worked. I tried setting many custom permalink styles, but they all had the same effect. If it was anything besides the default, I could not see anything but the front page.

    So I set the permalinks to default.

    Then I went to add a new site. The site URL should be http://gnawlidge.com/guitar/
    But I get a 404. I get a 404 when I type it in, and I get a 404 when I try to visit the site.

    The questions I have are, Is there a way to fix the permalinks so I don't have to use the default? And What do I need to do (or what suggestions do you have) to fix the problem of not seeing the second site?

  2. Do pretty permalinks work on the main site? Did they work before you turned on Multisite?

    Are you on Linux or Windows hosting?

  3. chisao101
    Member
    Posted 1 year ago #

    I didn't try it on the original installation, so I don't know if they worked on the site before setting up multisite.
    They do not work on the main site. That is where I first discovered the issue, before trying to add a new site.
    I have Linux hosting.

  4. Un-do Multisite and see if pretty permalinks work on the main site as a single install.

  5. chisao101
    Member
    Posted 1 year ago #

    just change the allow multisite to false, or go ahead and delete the stuff out of mysql too?

  6. chisao101
    Member
    Posted 1 year ago #

    I commented out the lines added in the wp_config file

    contents of .htaccess are:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    </IfModule>

    # END WordPress

    Dropped these tables:

    wp_blogs
    wp_blog_versions
    wp_registration_log
    wp_signups
    wp_site
    wp_sitemeta

    All Permalinks are working, all configurations.

  7. Okay :) That's good! (The reason we do this is to eliminate possible issues)

    Turn Multisite back on, but DO NOT make any new blogs. Just activate it and see if the permalinks still work.

    If they don't, try re-saving the permalinks (just go in and click save).

  8. chisao101
    Member
    Posted 1 year ago #

    Okay, I turned it all back on. I did not create any new sites.

    The permalinks are working correctly.

    I noticed something as I was setting the new code in the .htaccess. The code generated by WP was different the first time. There are more lines in the code from this time. The previous code is posted above. This is the new code:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    # END WordPress

    Could the problem have been caused by that?

  9. Depends on if you picked subdomains or subfolders the first time. You may have accidentally gotten the subdomain htaccess. :)

    Go ahead and make a new site.

  10. chisao101
    Member
    Posted 1 year ago #

    I made a new site and everything is working great now. I think you're right about getting the wrong .htaccess because that was the only thing that is different.

    Thanks for all your help. I'm going to mark this topic as resolved.

Topic Closed

This topic has been closed to new replies.

About this Topic