WordPress.org

Ready to get started?Download WordPress

Forums

WP Smush.it
[resolved] must be within the website home URL (21 posts)

  1. Hal
    Member
    Posted 11 months ago #

    v1.6.5.1 with new installation of WP installed in a subfolder ... attempting to add a 3.9K png file, gives the error mentioned in the title, and then a broken img icon in the media library. Multiple attempts give the same result. The file uploads fine to WP, and appears normal within the filesystem itself.

    http://wordpress.org/plugins/wp-smushit/

  2. Hal
    Member
    Posted 11 months ago #

    Sorry, that error was a setting unrelated to smushit. Back to the "bad response from smush.it" now.

  3. coupon999
    Member
    Posted 11 months ago #

    I have this error after update to 1.6.5.1: "must be within the website home URL"
    Didn't upload any new files, just trying to process the old one.

  4. coupon999
    Member
    Posted 11 months ago #

    Fixed: In WP dashboard,go to settings> media. Make sure there is nothing (no url) in the "Full URL path to files" field.

  5. Mike
    WPMU DEV Support Staff
    Posted 11 months ago #

    @coupon999

    Awesome did that fix the problem? Did this work for you also @Hal?

  6. coupon999
    Member
    Posted 11 months ago #

    It works for me. Thanks.

  7. Mike
    WPMU DEV Support Staff
    Posted 11 months ago #

    @coupon999 That's great thanks for pointing this out :-)

    @Hal Can you try this and let us know if this was the problem for you as well?

  8. rolfsmeets
    Member
    Posted 11 months ago #

    I have just installed the plugin. Several months ago I had been using it and it worked well. I got rid of it for some reason.
    But this time the plugin does not work.
    I get this error:
    — [original] 400 x 26 must be within the website directory
    same for medium and thumbnail.

    I do not know the reason.
    I also do see the: "Full URL path to files" field. in wp-dashboard media.

    Any advise or help is appreciated.

    rolf

  9. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 11 months ago #

    @rolfsmeets,

    Can you tell me what the value of that field is?

    Basically the plugin is attempting to make sure the path to the image is within your home directory.

  10. rolfsmeets
    Member
    Posted 11 months ago #

    Hi, that was quick!

    There is no field at all.
    There is the Use Smushit on upload and the: How many seconds should we wait field. That is all.

    Greetings, rolf

  11. Mike
    WPMU DEV Support Staff
    Posted 11 months ago #

    Hi @rolfsmeets

    I think he means the field that coupon99 was referring to when he said:

    Fixed: In WP dashboard,go to settings> media. Make sure there is nothing (no url) in the "Full URL path to files" field.

    Did you check that?

  12. rolfsmeets
    Member
    Posted 11 months ago #

    Hi, I made a typo in my first post: I also do see the: "Full URL path to files" field. in wp-dashboard media.
    This should read: I also do NOT see the: "Full URL path to files" field. in wp-dashboard media.
    All uploads are in folders ordered by year and month as was checked.
    so I still do not know what causes the problem.

    Rolf

  13. Mike
    WPMU DEV Support Staff
    Posted 11 months ago #

    Hi @rolfsmeets

    I didn't think to check before, but I've just had a look and apparently this was released in the last version, so let's move on!

    Have you enabled pretty permalinks?
    Have you tried with all other plugins disabled?

  14. rolfsmeets
    Member
    Posted 11 months ago #

    Hi,
    Permalinks are enabled. (format: http://ecopic.nl/2013/09/sample-post/)
    I have checked with other plugins disabled. I still get the error message.
    I also do not think that the received error points to a conflict with other plugins.

    Rolf

  15. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 11 months ago #

    @rolfsmeets,

    I just pushed out WP Smush.it 1.6.5.2. This version includes a debug output option. Go to Settings > Media. In the Smush.it section you will see a checkbox to enable debug output. Set that and save the settings. Then go over to Media > Bulk Smush.it. Run the bulk smash.it and grab us a copy of some of the debug output. It will show paths and such we need to help determine your exact issue.

    Thanks.

  16. rolfsmeets
    Member
    Posted 10 months ago #

    hi, I tried the new version and it seems to be working now!
    Here is some of the output of the debug file.
    regards, rolf

    Processing iceland-3-2…
    DEBUG: attachment_file_path=[E:\HostingSpaces\Smeets1\ecopic.nl\wwwroot/wp-content/uploads/2013/07/iceland-3.jpg]
    DEBUG: attachment_file_url=[http://ecopic.nl/wp-content/uploads/2013/07/iceland-3.jpg]
    — [original] 935 x 454: Reduced by 11.1% (35 KB) already smushed
    — [thumbnail] 150 x 72: Reduced by 5.8% (306 B) already smushed
    — [medium] 300 x 145: Reduced by 5.7% (900 B) already smushed
    — [post_box_img] 600 x 370: Reduced by 6.1% (3.9 KB) already smushed
    — [post_box_img_full] 900 x 390: Reduced by 6.1% (6 KB) already smushed
    — [static-header-img] 935 x 400: Reduced by 6.3% (7.8 KB) already smushed

    Processing iceland-2-2…
    DEBUG: attachment_file_path=[E:\HostingSpaces\Smeets1\ecopic.nl\wwwroot/wp-content/uploads/2013/07/iceland-2.jpg]
    DEBUG: attachment_file_url=[http://ecopic.nl/wp-content/uploads/2013/07/iceland-2.jpg]
    DEBUG: file_path [E:/HostingSpaces/Smeets1/ecopic.nl/wwwroot/wp-content/uploads/2013/07/iceland-2.jpg] ABSPATH [E:/HostingSpaces/Smeets1/ecopic.nl/wwwroot/]
    DEBUG: file_url [http://ecopic.nl/wp-content/uploads/2013/07/iceland-2.jpg] home_url [http://ecopic.nl]
    DEBUG: Calling API: [http://www.smushit.com/ysmush.it/ws.php?img=http%3A%2F%2Fecopic.nl%2Fwp-content%2Fuploads%2F2013%2F07%2Ficeland-2.jpg]
    DEBUG: return from API: data

    stdClass Object
    (
    [src] => http://ecopic.nl/wp-content/uploads/2013/07/iceland-2.jpg
    [src_size] => 288548
    [error] => No savings
    [dest_size] => -1
    [id] =>
    )

    DEBUG: attachment_file_path_size=[E:\HostingSpaces\Smeets1\ecopic.nl\wwwroot/wp-content/uploads/2013/07/iceland-2-150x106.jpg]
    DEBUG: attachment_file_url_size=[http://ecopic.nl/wp-content/uploads/2013/07/iceland-2-150x106.jpg]
    DEBUG: file_path [E:/HostingSpaces/Smeets1/ecopic.nl/wwwroot/wp-content/uploads/2013/07/iceland-2-150x106.jpg] ABSPATH [E:/HostingSpaces/Smeets1/ecopic.nl/wwwroot/]
    DEBUG: file_url [http://ecopic.nl/wp-content/uploads/2013/07/iceland-2-150x106.jpg] home_url [http://ecopic.nl]
    DEBUG: Calling API: [http://www.smushit.com/ysmush.it/ws.php?img=http%3A%2F%2Fecopic.nl%2Fwp-content%2Fuploads%2F2013%2F07%2Ficeland-2-150x106.jpg]
    DEBUG: return from API: data

    stdClass Object
    (
    [src] => http://ecopic.nl/wp-content/uploads/2013/07/iceland-2-150x106.jpg
    [src_size] => 9245
    [dest] => http://ysmushit.zenfs.com/results/fb865d7e%2Fsmush%2Fwp-content%2Fuploads%2F2013%2F07%2Ficeland-2-150x106.jpg
    [dest_size] => 8545
    [percent] => 7.57
    [id] =>
    )

  17. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 10 months ago #

    @rolfsmeets,

    Excellent. Thanks for finding and providing the debug output!

  18. Info2tv
    Member
    Posted 10 months ago #

    Hi,
    I have the same problem with WP Smush.it plugin : ".jpg must be within the website home URL"
    What can I do to resolve it ?
    Thanks

  19. Mike
    WPMU DEV Support Staff
    Posted 10 months ago #

    Hi @Info2tv

    This thread is marked as resolved so we may miss your comments, it might be best to start your own thread.

    However please ensure that you are using the latest version. If you already are then please enable debug mode and then try smushing images again and then copy your error log and paste it here or in a new thread.

  20. Info2tv
    Member
    Posted 10 months ago #

    Hi Mike,

    Thanks for your response. I'll start a new thread 'bout WP Smush;it plugin.

  21. Mike
    WPMU DEV Support Staff
    Posted 10 months ago #

    Ok that's great, thanks :-)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.