WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Multisite with sub-directories (5 posts)

  1. lizottej
    Member
    Posted 3 years ago #

    Hello,

    I install worpress 3.04 and activate multisite with sub-directories. My problem is that when i create a site with the tools super-admin, that doesn't create the folder and i try to update network and i receivre error fopen.

    I use Linux with apache, mysql and php 5.2.5. The allow fopen url was activate, the apache rewrite function was activate too.

    This is the url of my wordpress site http://www.clevislauzon.qc.ca/Enseignement/ i try to create a site biblio and the url should be http://www.clevislauzon.qc.ca/Enseignement/biblio but that dows not seem to work.

    I try to manually create the folder biblio and that does not working.

    this the content of my .htaccess file:

    RewriteEngine On
    RewriteBase /Enseignement/
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    What i missing and can someone help me ?

    Thanks a lot.

  2. Don't manually create the folder. That WILL break things.

    This also fails: http://www.clevislauzon.qc.ca/Enseignement/blog/2011/01/17/bonjour-tout-le-monde/

    So either your .htaccess file is in the wrong place (it should be in the Enseignement folder) OR it's not being read. Ask your host for assistance.

  3. lizottej
    Member
    Posted 3 years ago #

    Hello,
    My .htaccess file was in the Enseignement directory, i think that is not being read. I am the host of the apache server. I search to apache problem and i see that the command allowoverride should not be none . What does this command should be to read the .htacess file correctly ?

  4. I believe it should be set to 'all' but I'm not 100% certain.

  5. lizottej
    Member
    Posted 3 years ago #

    Hi,

    You have write, this is the two options that i put to my config of apache under directory dirrective:
    AllowOverride all
    Option FollowSymLinks

    And that work great....
    Thanks you very much for your help...

Topic Closed

This topic has been closed to new replies.

About this Topic