WordPress.org

Ready to get started?Download WordPress

Forums

Multisite uploads (1 post)

  1. robcwright
    Member
    Posted 3 years ago #

    I've been fighting with 3.04 Multisite and now 3.1 RC2 trying to get uploads to behave the way I think they should. I'm trying to get the files that are uploaded to the main blog to register in the media library with an upload location of /files/year/month/name, but it will not work.

    By default, blog ID 1 uses the standard wp-content/uploads folder as its default upload location. Once enabling multisite, the new sites use wp-content/blogs.dir/siteID/files/etc. When an image is uploaded to a child site, the listed location is /files/year/month/name, not blogs.dir. Hence the need for the htaccess rule to rewrite it to ms-files to figure out where it belongs.

    I've tried hard coding /blogs.dir/1/files into the network admin for my main site. WP will upload to that direct and display it externally with no problems, but it still shows up in the media library with the /blogs.dir address and not under files. I want the media library and the posts to show the /files/ url and not the /blogs.dir/ url, but I can't quite figure it out.

    I have another install that this is working perfect on and I can't figure out the difference other than the old site that is working as it should cam from WPMU and was upgraded to WP 3.

    Any thoughts would be greatly appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic