WordPress.org

Ready to get started?Download WordPress

Forums

Multisite switching between dashboards (9 posts)

  1. sandrews1717
    Member
    Posted 1 year ago #

    I just installed Multisite for 2 sites. From my admin panel, if I switch to the primary site dashboard, it's fine and it still says "My Sites" at the top. But when I switch to the secondary site, I get to the dashboard for that site, but now there is nothing at the top to allow my to go back to the primary site. Also, everytime I go to the secondary site dashboard, it makes me login again.
    How do I make it easier to switch between dashboards? I am the super admin and admin on both sites

  2. leejosepho
    Member
    Posted 1 year ago #

    I have a self-hosted site along with a site at wordpress.com, and JetPack does that same kind of thing. It will let the Dashboard at the self-hosted site show/access the other, but the Dashboard at the wordpress.com site cannot do that. Maybe you have a similar situation?

  3. If you use sub domains or mapped domains, you often have to log in again due to cookies and shenanigans outside of WP. However. It sounds like you have two separate sites and not a network. Are you logging in with the same ID on both sites?

  4. sandrews1717
    Member
    Posted 1 year ago #

    yes I use the same login on both. And when I am on the main site It says "My Sites" at the top and lists both of them, so I know I have a network. From the main dashboard I can click to the primary site dashboard and back no problem. And I can click to the secondary site no problem. But once I get to the secondary site there is nothing to let me go back to the first one or the main admin dashboard.

  5. But once I get to the secondary site there is nothing to let me go back to the first one or the main admin dashboard.

    If my sites is missing, it really sounds like this isn't a multisite. The alternative is you have a plugin that's killing it.

  6. sandrews1717
    Member
    Posted 1 year ago #

    Seriously, it is multisite. Only when I am on the second site can I not see "My Sites". On the main site, "My Sites" is there and shows both of my sites

    I installed WordPress on the 2nd site from the main one. It was a fresh install. I enabled multisite on my first site, and created a second one from there. It is definitely multisite.

    and I only have 5 plugins, and I have tried disabling them all and it still doesn't work.

  7. *ponder* There's a fast way to test. On your second site, what's the URL for your images?

  8. sandrews1717
    Member
    Posted 1 year ago #

    The URL links to the 2nd site library. It's as if site 1 knows it is multiisite including site 2. But site 2 is unaware it is part of the multisitte.

    Is there something I have to do on the child site to make it part of the multisite? I thought all the setup was done on the parent site.

  9. The URL links to the 2nd site library.

    Not what I asked :) What's the URL?

    It SHOULD be domain.com/site/files/2012/....

    Is it?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.