WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Multisite subsite backend gives 404 (4 posts)

  1. lijndiensten
    Member
    Posted 1 year ago #

    Hey All - I have set up a multisite with subdomains today, which all seemed to be going well. The main site stayed online, and I could add an additional site, but then got a 404 on the front- and backend of the site.

    For the frontend I then added the specific subdomain 'retro' in Plesk, since my hosting (hosting2go.nl) does not allow wilcards. Now it's giving a generic Plesk page, informing me there is no index.html. (link)

    The backend keeps giving a 404 error on retro.baotian-scooters.net/wp-admin/. Below the wp-config and htaccess. I hope someone can help, thanks already!

    HTACCESS - from line 1

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    WP-CONFIG - from below the first 20 or so lines.

    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);
    
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'www.baotian-scooters.net');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    define( 'SUNRISE', 'on' );
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    (Sunrise is there, because I thought it could be a fix, but the subsite doesn't work with or without, as the reader might have foreseen...)

  2. For the frontend I then added the specific subdomain 'retro' in Plesk, since my hosting (hosting2go.nl) does not allow wilcards. Now it's giving a generic Plesk page, informing me there is no index.html. (link)

    Right, you have point it to where baotian-scooters.net is installed. By default, subdomains go to baotian-scooters.net/retro

    Just change that.

    if you don't know how, ask your host this: "How do I point a subdomain to the location of my main domain?"

  3. lijndiensten
    Member
    Posted 1 year ago #

    Hi Mika - thanks for the swift response. I asked my host your suggested question and they replied quite briefly that they do not allow this configuration. Bummer.

    So for Dutch users using Hosting2go, Multisite through their servers appears to be a no-go.

  4. Diplo
    Member
    Posted 10 months ago #

    Hi Lijndiensten,

    I just made a multisite installation of WP in Hosting2go. After reading your posts here, I decided to use the option "Subdirectories" and it works fine (I tested with 3 subdirectories and one user per sub). I would suggest you to give it a try.

    If you would like to use subdomains though (and after reading the advice of Mika), you might create the subdomain in Plesk and upload an index.php file with this code in each subdomain (replace "yoursite.com/subdomain" with the proper name):

    <?php
    $url2redirect = $_SERVER['REQUEST_URI'];
    header( "Location: http://yoursite.com/subdomain" . $url2redirect ) ;
    exit;
    ?>

    With the hope that WordPress will display the subdomain url structure. You might try to create the subdomain directly in the /subdomains/ folder in your server, skipping Plesk... I haven't tested at all, just a wild guess.

    Hope it helps!

Topic Closed

This topic has been closed to new replies.

About this Topic