WordPress.org

Ready to get started?Download WordPress

Forums

Multisite subdomain 500 error problem (11 posts)

  1. Pradip Nichite
    Member
    Posted 1 year ago #

    i have create multisite network using subdomain method.when i create new side n visit it shows like this

    Index of /

    cgi-bin/

    when i visit dashboard of new site i saw this error

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@projects.crazyfornet.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    please help me ,my wildcard domains work properly only new sites create problem

  2. when i create new side n visit it shows like this

    Index of /

    cgi-bin/

    I'm psychic. You're using subdomains. You did not set up wildcard subdomains on your server.

  3. Pradip Nichite
    Member
    Posted 1 year ago #

    thanks for responding,I have set up wildcard sub domains and it also working .only problem is that i am not able to see my newly created site and whenever i click on dashboard of new site it shows me error 500

  4. I have set up wildcard sub domains and it also working

    Do you mean it's now working? It wasn't before, per what you said.

  5. Pradip Nichite
    Member
    Posted 1 year ago #

    ya its working now ,problem is i am not able to see my new site and dashboard,i have created one subdomain manualy its also working,only multisite network sites not working.plz help me

  6. problem is i am not able to see my new site and dashboard

    What do you mean? You just said subdomains work.

    What, exactly, is the problem here? Either the subdomains works and sub.domain.com shows what it should or it's broken and doesn't. You can't have both :) IF wildcard subdomains are working correctly, going to anything.yourdomain.com will have a WordPress result.

    Go to foobarbaz.ipstenu.org - See how it redirects? That's how I know wildcards are working :)

  7. Pradip Nichite
    Member
    Posted 1 year ago #

    thank u for replay,sub domains working means anything.mysite.com
    results to mysite.com there is no problem.But when i create new site using multisite it's not working.
    Suppose i create sub site abc and i type abc.mysite.com in url it shows error

    ndex of /

    cgi-bin/

    and when i tried to go dash board of new site it shows error 500.
    pls help me

  8. sub domains working means anything.mysite.com
    results to mysite.com

    Does it JUST redirect to mysite.com or does it go to http://mysite.com/wp-signup.php?new=anything (this is very important!!!)

  9. Pradip Nichite
    Member
    Posted 1 year ago #

    Yes it redirects to sign up page of multisite network.
    anything.mysite.com redirect to http://mysite.com/wp-signup.php?new=anything

  10. Pradip Nichite
    Member
    Posted 1 year ago #

    This is my wp-config.php file

    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'crazyfornet.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    and this is .htaccess file

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    pls help

  11. Thats the wrong .htaccess for subdomains. Read http://codex.wordpress.org/Multisite_Network_Administration#.htaccess_and_Mod_Rewrite

    Now.

    Multisite works just fine. it's supposed to redirect any non existant subdomains to that signup URL - http://mysite.com/wp-signup.php?new=anything

    The real question is what happens when you got a REAL subdomain, ie one you've create? Where does that go?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags