WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Multisite Subdirectory New Site redirect loop error Need help (11 posts)

  1. Lindsay Green
    Member
    Posted 10 months ago #

    I download a fresh install of 3.6.1 and activated network. Everything appears to be working smoothly, but it will not allow me to access my new site's dashboard. I can get to the site page from my list of site, but there is no formatting on the site.
    Please help,
    Thank You.

  2. Read through: http://halfelf.org/2012/multisite-login-loop/

    I can get to the site page from my list of site, but there is no formatting on the site.

    Is your .htaccess correct?

  3. Lindsay Green
    Member
    Posted 10 months ago #

    I cannot find the .htaccess file anywhere.
    When I did the network setup it never prompted me to edit the .htacess file. It instead had me place/replace code in my web.config and wp-config files.

  4. Ahh, you're on IIS :) That's different.

    Did you replace the old WP calls in web.config? Sometimes people accidentally append.

  5. Lindsay Green
    Member
    Posted 10 months ago #

    What is IIS?

    I did replace the calls.

  6. IIS is Windows Servers. http://www.iis.net/

    90% of WP users have Linux/Unix servers.

    Is mod_rewrite enabled on your server?

  7. Lindsay Green
    Member
    Posted 10 months ago #

    I am not sure. I just read something about that and was going to check. I am guessing I check that on my godaddy account somewhere?

  8. Lindsay Green
    Member
    Posted 10 months ago #

    Should I have a .htaccess file instead of a web.config?

    Also, apparently godaddy already has the mod_rewrite enabled. They say you don't have to go on and do anything, but I am questioning that.

  9. Lindsay Green
    Member
    Posted 10 months ago #

    So I figured this out for the most part.

    I switched to a Linux hosted site on my godaddy account. I could not find any fix for multisite subdirecory hosting on windows server.

    Once I switched and went through the motions it all worked fine!

    Thank You for your help:)

  10. jasonlicn@hotmail.com
    Member
    Posted 9 months ago #

    I switched to a Linux with godaddy. It solved my problem a lot. Thanks a lot. I spent a few days with this issue on a Windows box.

  11. hunt
    Member
    Posted 3 weeks ago #

    For IIS ..replace below with web.config file

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
      <system.webServer>
        <rewrite>
          <rules>
            <rule name="WordPress Rule 1" stopProcessing="true">
              <match url="^index\.php$" ignoreCase="false" />
              <action type="None" />
            </rule>
            <rule name="WordPress Rule 2" stopProcessing="true">
              <match url="^([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
              <action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
            </rule>
            <rule name="WordPress Rule 3" stopProcessing="true">
              <match url="^" ignoreCase="false" />
              <conditions logicalGrouping="MatchAny">
                <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
              </conditions>
              <action type="None" />
            </rule>
            <rule name="WordPress Rule 4" stopProcessing="true">
              <match url="^" ignoreCase="false" />
              <conditions logicalGrouping="MatchAny">
                <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
                <add input="{URL}" pattern="([a-zA-Z0-9\./_-]+)\.axd" />
              </conditions>
              <action type="None" />
            </rule>
            <rule name="WordPress Rule 5" stopProcessing="true">
              <match url="^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*)" ignoreCase="false" />
              <action type="Rewrite" url="{R:1}" />
            </rule>
            <rule name="WordPress Rule 6" stopProcessing="true">
              <match url="." ignoreCase="false" />
              <action type="Rewrite" url="index.php" />
            </rule>
          </rules>
        </rewrite>
        <httpRedirect enabled="false" destination="http://www.yourdomain.com" />
      </system.webServer>
    </configuration>

Reply

You must log in to post.

About this Topic