WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Multisite sub-blog pictures won't import/broken links (7 posts)

  1. w.pitt
    Member
    Posted 1 year ago #

    I have a wordpress multisite installed on a (domaine.net). I'm building websites here (domain.net/site1) or (domain.net/site2).

    I have .htaccess looks like this:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>

    I think the problem is where my (domain.net folder is installed) In my cpanel when I access my files I click on the (WWW)/then I click on (domain.net)/ is that the problem? because it's not in the root folder?

    Problem is I can use the main "domain.net" without any problems. I cannot add any images to the "domain.net/site1 or domain.net/site2"

    The images appear as broken links or return a 404 error when I enter their URL manually.

    Image URL: http://boulos.net/quebec-insurance-investment-blog/files/2013/05/header-blog.jpg

    Permalinl: http://boulos.net/quebec-insurance-investment-blog/?attachment_id=61

    Thanks to all who answer!! If you need any more information please ask! :)

  2. This works: http://boulos.net/quebec-insurance-investment-blog/wp-includes/ms-files.php?file=/2013/05/header-blog.jpg

    So the problem is you don't have allowoverride set to All (or possibly Options All) in your httpd.conf

    Your server doesn't like the complex .htaccess rules, so have it edited to use that.

  3. w.pitt
    Member
    Posted 1 year ago #

    How come your link works? Why doesn't my website pull the image up?

    As for the httpd.conf I contacted my hosting company for that issue before I posted here and this was there response: "Unfortunately we do not allow to modify apache configuration file for particular domain. This setting is not supported at this time."

    How can I edit my .htaccess for my server to read the .htaccess ?

    Thank you so much for your help!!

  4. w.pitt
    Member
    Posted 1 year ago #

    Hi Mika,

    I just wanted to bring this up. I started reading your mulitisite Ebook and found a mistake in my multisite install. On page 14 of your ebook you mention that we shouldn't have database prefix's using numbers.

    I presently have DB1, DB2, and DB3. Would that be part of the problem? Wouldn't that create improper links because (you mentioned) "cause conflicts with the numbering structure WordPress uses per-sire"

    Thank you Mika!!

  5. w.pitt
    Member
    Posted 1 year ago #

    Please also note,

    In my CPanel/phpmyadmin I do not have tables such as "wp_1_comments"

    I only have "wp_comments"
    then jumps to "wp_2_comments"

    Therefore my database tables aren't okay?

  6. w.pitt
    Member
    Posted 1 year ago #

    Thanks for your help!!

  7. w.pitt
    Member
    Posted 1 year ago #

    I solved the Issue by correcting the .htaccess code.

    there was missing ([_0-9a-zA-Z-]+/) before the ?files in the upload files section.

    Thanks again Mika! :)

Topic Closed

This topic has been closed to new replies.

About this Topic