WordPress.org

Ready to get started?Download WordPress

Forums

Multisite showing new site w/ no template and no dashboar (11 posts)

  1. chuck0
    Member
    Posted 1 year ago #

    I've used WP MU for several years for one of my sites, but this is the first time I've run across this suite of problems. I've set up a new installation of WordPress an enabled the network. Set up the main site yesterday with no problems. The multisite network is configured to store additional sites in directories--we plan to point domains at the directories.

    The main site:
    http://homesforsaleleawood.com

    The second site on the network (with problems):
    http://homesforsaleleawood.com/test/

    The second site isn't showing any style sheet and the dashboard for the second site generates an error page that says: "The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

    It smells like a directory path problem. I've installed the proper network code in the wp-config.php and .htaccess files for the parent site.

    Any ideas?

  2. What's the full .htaccess content? cause... 99% of the time it's wrong when this happens :)

  3. chuck0
    Member
    Posted 1 year ago #

    Yep, it's usually something obvious. Here you go:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
  4. chuck0
    Member
    Posted 1 year ago #

    This is the bottom of the wp-config.php file.

    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    /* Multisite */
    
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'homesforsaleleawood.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
  5. That's the full .htaccess? Nothing else extra?

    At that point, the next place to look is your AllowOverride settings in httpd.conf.

  6. chuck0
    Member
    Posted 1 year ago #

    That file is empty. What should go there?

  7. Where are you looking? It can't be empty or nothing will show. That's a server wide file.

  8. chuck0
    Member
    Posted 1 year ago #

    /etc/apache2/

    I know, I was surprised to find it empty.

    Is this something I should talk to the hosting company tech support about?

  9. Yeah, ask them if 'AllowOverride' includes 'All' :)

  10. matuh
    Member
    Posted 11 months ago #

    Did you find a solution?
    I have the exact same problem.

  11. matuh
    Member
    Posted 11 months ago #

    Or does anybody else have a solution?

Topic Closed

This topic has been closed to new replies.

About this Topic