WordPress.org

Ready to get started?Download WordPress

Forums

multisite problem (3 posts)

  1. salvig67
    Member
    Posted 1 year ago #

    I have tried a number of things. This is the first network I am setting up.

    I followed the instructions to a T and keep getting a few different problems.

    When I replaced the .htaccess with this.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

    I received a 500 internal server error and when I change back to the original backup file it works.

    The changes made to the wp-config was this:

    */
    define('WP_DEBUG', false);
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'salsclub.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    But it will not go to demo.salsclub.com I get this error for created site.

    Server not found

    Firefox can't find the server at demo.salsclub.com.
    Check the address for typing errors such as
    ww.example.com instead of
    http://www.example.com
    If you are unable to load any pages, check your computer's network
    connection.
    If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.

    I tried two different installations with the exact same results.

    I saw a article that was written about this code:

    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    On person said to define the DB_COLLATE Is that why I am having the same problem.

    I appreciate any input for this very much thanks in advance.

    Sal

  2. No, I have DB_COLLATE set the same way, and it's fine.

    Error 500 is usually related to your .htaccess not being read correctly.

    See if you have allowoverride set to 'all' in your httpd.conf file. (Ask your host if you don't know what that means)

  3. salvig67
    Member
    Posted 1 year ago #

    Thanks will check it out I appreciate your time.

    I am thinking the host may not allow it on the server.

    I may need a virtual dedicated server to do this.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.