WordPress.org

Ready to get started?Download WordPress

Forums

Multisite problem - 403 & 404 html errors (8 posts)

  1. harry2fish
    Member
    Posted 1 year ago #

    Hi

    I've installed wordpress in the root folder of the primary domain of my hosting account. I have 6 other domains, which are addon domains in the same hosting account, which I want to run the same wordpress installation.

    I have followed the steps and edited wp-config.php and .htaccess. The network admin menu appeared in my control panel and I have added some of the sites to the network. However, when I visit the newly added sites I get a 403 forbidden error:

    Forbidden

    You don't have permission to access / on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    And when I try to go to the dashboard of any of the new sites I get a 404 not found error:

    Not Found

    The requested URL /index.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Now, there was nothing installed on these domains to begin with, so there is no index or htaccess file in their directories, only the ones in the root of the primary domain.

    Am I making much sense? Can anyone help me out?

    Thanks a bunch! H

  2. ScottCCC
    Member
    Posted 1 year ago #

    I'm sorry I'm not any help here but I'm having the same issue. Have you found a resolution?

  3. harry2fish
    Member
    Posted 1 year ago #

    Hi Scott,

    I think I figured out the problem - I am trying to have the network sites all on separate domains, not just subdomains or subfolders of 1 domain. I realise now that the multisite feature doesn't work across external domains, only subdomains/subfolders. There is a plugin that lets you map the network sites to external domains, here is the link: http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

    I hope that helps you.

    If you are not trying to map the sites to external domains, but you are getting 403 errors, check with your host that Apache mod_rewrite is enabled. That apparently fixes these errors in some cases.

    H

  4. ScottCCC
    Member
    Posted 1 year ago #

    Thanks for the quick response.

    I'd installed the domain-mapping piece. My problem turned out to be that because I installed WP in the root directory of my main site I needed to use parked domains (rather than add-on domains) for domain mapping purposes. Once I did that everything fell into place.

  5. You have to walk before you run.

    Put aside the desire to map domains for a moment, and concentrate on the subsites :) Without the domains at all involved, you set up domain.com/sitename (or sitename.domain.com)

    Do those work? If not, what error are you getting?

  6. harry2fish
    Member
    Posted 1 year ago #

    Hi Mika

    I enabled wildcard dns and chose sub-domain network, but I wanted to keep the www prefix on the main site (lets call it http://www.network.com). So when I create the new sites in the network admin, I'm not sure whether to put

    http://www.subsite1.network.com

    or

    http://www.subsite1.www.network.com

    as the site address. When I try either of the above, the new site appears in the list of sites but if I click on 'Dashboard' or 'Visit', it takes me to a BT Yahoo! page that says

    Sorry, the website subsite1.network.com cannot be found.

    Yesterday when I was doing the same thing it showed me either a 403 or 404 error, but its not doing so today for some reason.

    I feel like I'm going round in circles at the moment, would really appreciate some help!

  7. harry2fish
    Member
    Posted 1 year ago #

    I didn't change a thing since yesterday, and suddenly it is all working. Maybe the wildcard subdomain took some time to propogate? Who knows. Now onto domain mapping.

    Thanks for the help guys.

    H

  8. Maybe the wildcard subdomain took some time to propogate?

    Usually an hour, but up to 72, yes :)

Topic Closed

This topic has been closed to new replies.

About this Topic