WordPress.org

Ready to get started?Download WordPress

Forums

Multisite Pretty Permalinks on IIS 6 (2 posts)

  1. mvbaxter
    Member
    Posted 1 year ago #

    I have searched blogs and tutorials for three days and found several answers that almost matched my circumstances, but all seemed to have Pretty Permalinks working or NOT working. In my case, they work, but not for my root site.

    Using examples from several whose issues seemed closest to my situation, I have tried many different versions of .htaccess and changed directory and file permissions repeatedly.

    I currently have a fresh subdirectory multisite setup according to the directions in the codex. I am running this on IIS 6 with IIS Mod-rewrite Pro. The following is my .htaccess file, located in the subdirectory folder with my wp-config:

    #------------ .htaccess ---------------#
    #added FollowSymlinks as suggested by codex
    Options FollowSymLinks

    RewriteEngine On
    RewriteBase /kpnvly/
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule ./index.php [L]
    #-------------------------------#

    I am trying to use "/%year%/%postname%/" or "/%category%/%postname%/". I can get either pattern to work for every site except the root / "first" site (Site=1). Every time I remove the "/index.php" from the "custom" option in site 1, it gets automatically added back.

    I even tried changing $is_apache = 1 as recommended by Fixing Permalinks, but then I get native IIS 404 errors throughout the root site.

    In case it helps, here is the multisite section of my wp-config too:

    define('WP_ALLOW_MULTISITE', true);
    
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'cnrpwwebd001');
    define('PATH_CURRENT_SITE', '/kpnvly/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    define('WP_DEFAULT_THEME', 'kaiser');

    Please tell me I'm not stuck with "/index.php".

  2. zappmania
    Member
    Posted 1 year ago #

    I was able to get it working on my site. my site is on IIS (Windows hosting).
    try below link may this steps helps you too...

    http://www.zappmania.in/index.php/2013/03/27/getting-wordpress-pretty-permalinks-working-on-iis-windows-hosting/

Topic Closed

This topic has been closed to new replies.

About this Topic