WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Landing Pages
[resolved] Multisite Permalink 404 (10 posts)

  1. fjones18
    Member
    Posted 1 year ago #

    I'm running a multisite installation with an English version of the site and a Spanish version of the site. The Landing Pages plugin is installed for use on both sites. The English site is at domain.com and the Spanish site is at domain.com/es.

    I can create a landing page on the English site without any problems.

    When I create a Spanish landing page, I can view it using the preview option before it is published. However, when I setup the permalink and publish the page I get a 404 error. For example, I can preview the post with a link similar to domain.com/es/?post_type=landing-page&p=526. However, I get a 404 error when I publish the post and set the permalink to domain.com/es/test.

    Any help is appreciated.

    http://wordpress.org/plugins/landing-pages/

  2. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    Are you using the double headline translation plugin? We've seen it cause errors before.

  3. fjones18
    Member
    Posted 1 year ago #

    I'm not using that plugin. Any other suggestions?

  4. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    Whats the permalink structure?

  5. fjones18
    Member
    Posted 1 year ago #

    Both sites use /%postname%/ for the permalink structure.

  6. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    Hmmm not sure what the issue is.

    You say it works on base multisite instance but not on a sub-folder version?

    Sounds like it might be a plugin/theme conflict.

    To test for a theme conflict:

    1. Activate default Twenty Ten, Eleven, Twelve, or Thirteen theme
    2. Check to see if the issue still occurs
    3. If the issue does not occur after having activated the default "Twenty" theme, your theme is causing a conflict with landing pages.

    To test for a plugin conflict:

    1. Deactivate ALL plugins
    2. Activate Landing Pages
    3. Check to see if the issue occurs

    If the issue does not occur, one (or more) of your plugins is causing a conflict with Landing Pages.

    To determine which plugin(s) is causing the conflict, follow these steps:

    1. Activate each plugin one by one
    2. Check to see if the issue occurs after each plugin is activated
  7. fjones18
    Member
    Posted 1 year ago #

    I'll get back to you on those test in a moment. I just noticed another clue in the error page. The addresses I provided above weren't correct, sorry.

    The 404 error page reports I tried going to http://mysite.com/es/es/go/test/

    However, the page I'm trying to get to should be at http://mysite.com/es/go/test/

    For some reason a second /es is being added to the address when I get this error message.

    The address on the English site, which works, is: http://mysite.com/blog/go/test/

  8. fjones18
    Member
    Posted 1 year ago #

    I tested the theme using Twenty Thirteen and the issue remains. I also deactivated all the other plugins (only Landing Pages was active) and the issue remains.

  9. fjones18
    Member
    Posted 1 year ago #

    I just updated the Landing Pages plugin and tried to view the A/B Testing Landing Page Example. To my surprise the page came up on the Spanish site. So, I tried loading the landing page I created and it also came up. It seems the issue was fixed with the latest plugin update.

    Thanks!

  10. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    Glad everything worked out with the new updates!

    If you like the plugin, we would love a review from you on the WordPress Plugin Repository, it would really help us out!

    You can leave a review here.

    Thanks and let me know if you have any questions about the plugin.

    - David

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic