WordPress.org

Ready to get started?Download WordPress

Forums

Multisite Not working on windows hosting (2 posts)

  1. SoumyaKantiSar
    Member
    Posted 4 months ago #

    i recently installed wordpress on two locations
    1. http://www.sarsoft.co
    2. http://www.sites.sarsoft.co

    i enabled multisite in the second one because i want my own site like wordpress.com

    so now my web.config looks like this....

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <rewrite>
                <rules>
                    <rule name="WordPress Rule 1" stopProcessing="true">
                        <match url="^index\.php$" ignoreCase="false" />
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 2" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
                        <action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
                    </rule>
                    <rule name="WordPress Rule 3" stopProcessing="true">
                        <match url="^" ignoreCase="false" />
                        <conditions logicalGrouping="MatchAny">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
                        </conditions>
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 4" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)" ignoreCase="false" />
                        <action type="Rewrite" url="{R:1}" />
                    </rule>
                    <rule name="WordPress Rule 5" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
                        <action type="Rewrite" url="{R:2}" />
                    </rule>
                    <rule name="WordPress Rule 6" stopProcessing="true">
                        <match url="." ignoreCase="false" />
                        <action type="Rewrite" url="index.php" />
                    </rule>
                </rules>
            </rewrite>
        </system.webServer>
    </configuration>

    and my wp-config.php looks like this.....

    <strong>[Moderator Removed Database Info]
    </strong>
    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'sites.sarsoft.co');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** WordPress absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    
    //--- disable auto upgrade
    define( 'AUTOMATIC_UPDATER_DISABLED', true );
    
    ?>

    i have enabled subdirectories sites but when they are loaded they do not pull the stylesheet and also their dashboard is unaccessible.

    i currenty have a site http://sites.sarsoft.co/test/

    which is the victim of this problem. i allowed override in my web.config but still it did not worked. please help.. also let me know if there are other options for creating a webhosting site like wordpress.com with wordpress..

  2. DO NOT EVER EVER EVER POST YOUR DB CREDENTIALS AND INFORMATION ON A PUBLIC NETWORK.

    Go change those passwords RIGHT NOW.

    So the problem is your server doesn't understand this:

    http://sites.sarsoft.co/test/wp-content/themes/twentyfourteen/style.css

    That should, via your web.config, redirect. The problem ... I have no idea what it really looks like on IIS. It SHOULD be the WordPress Rule 4 and that looks okay...

    Is that the web.config provided by WP during creation of the network?

Reply

You must log in to post.

About this Topic

Tags