WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] multisite network admin 404 errors (11 posts)

  1. thegblog
    Member
    Posted 2 years ago #

    I have a site I just changed over to multisite. It was working like a charm, but after playing around with buddypress, I'm now having an issue where I am unable to access the network admin page. When I click on network admin under howdy username, I get a 404 error page. I've deleted all my plugins, changed the theme and still have been unable to access this.

    I am able to access both my network sites admin, just not the network admin itself. All posts are posting

    I've searched the engines and the forums here, but can't find an answer to this specific issue. Any help is appreciated

  2. Did you make any changes to your .htaccess file?

    Is the /wp-admin/network folder still there on your server?

  3. thegblog
    Member
    Posted 2 years ago #

    wp-admin/network folder is on the server.

    I did make changes to my .htaccess, but only after this started to happen. I'll try to paste the .htaceess info below:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    thanks

  4. Cuold you get into the network admin when BP was on?

  5. thegblog
    Member
    Posted 2 years ago #

    yeah, it actually started when I was trying to build the forums on buddypress, I got "you do not have permission to do this" or something and then when I hit back and tried again, I got the 404.

    I have deleted the buddypress plugin from the plugin folder via ftp now

  6. thegblog
    Member
    Posted 2 years ago #

    Okay, I was able to fix this issue by changing the permissions of wp-admin to 755. Not sure how that got changed in the first place.

  7. Uh ... Okay no. No no. Bad server! No cookies!

    wp-admin should never be 775! That's writable for heaven's sake! wp-content, I could see. But wp-ADMIN!? If your server requires that, you have other issues.

  8. thegblog
    Member
    Posted 2 years ago #

    How about 755? :> What permissions do you recommend for wp-admin?

  9. Ohhh I read it as 777 and typed 755 and ... I need more coffee. 755 is okay. 777 is baaaad.

  10. Grant
    Member
    Posted 2 years ago #

    @thegblog
    The permissions for wp-admin may never have been changed in the first place.

    I'm not certain what method you may have used, but I used the File Manager in cPanel to change file permissions for all the files and folders located in the root directory to 755, but I noticed that the files in all of the sub-directories were still 775, including wp-admin.

    cPanel's File Manager isn't the most thorough way to go about setting file permissions I notice. I believe setting them through the terminal is a more effective method.

  11. Grant
    Member
    Posted 2 years ago #

    Setting permissions with SSH access via Terminal:

    1. ssh -p [$port] [$user]@[$ip]

    [$port] = port number with no colon (ex: 22, 80)
    [$user] = FTP username
    [$ip] = server IP address

    2. Enter password
    Note: Terminal may or may not make typed characters visible. I recommend copying and pasting the password and hitting enter.

    3. chmod 755 -R /home/[$user]/public_html

    [$user] = FTP username
    Note: -R is case sensitive

Topic Closed

This topic has been closed to new replies.

About this Topic