WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] MultiSite - login causes Internal Server Error (16 posts)

  1. Realtime64
    Member
    Posted 7 months ago #

    Hi!

    I'm running a WP 3.8 MultiSite on my dedicated, managed server. Because the server is managed, I use subfolder instead of subdirs.

    The problem is the use of the links.

    Example: Admin login on a multisite via the meta-widget. The link for the "test" site is
    http://domain.de/test/wp-login.php
    If user "test" click on the link, he got an "Internal Server Error". User "test" could enter the dashboard via
    http://domain.de/wp-login.php
    that's no problem.

    I try serveral things posted here, I read two books how to setup a multiside. Nothing. I think, I have made the right settings in the WP Network Settings, wp_config.php and .htaccess.

    Does anyone have an idea?

    TIA!

    Marc

  2. Because the server is managed, I use subfolder instead of subdirs.

    I ... have no idea what that has to do with anything. Do you mean you're on a managed WP host? A dedicated server allows subdomains or subfolders.

    What's in your .htaccess?

  3. Realtime64
    Member
    Posted 7 months ago #

    Hi Mika!

    I started with an empty managed server. And you are right, I can apply subdirs manually in my server config. But if I read that wordpress creates the subdirs self, I expected problems on my managed server. So I decided to use subdirs.

    And I expected also that there is a different in between the configuration of my installation, so I wrote that "I use subfolders instead of subdirs".

    (Sorry, I wrote german much better than english ... ;-) )

    my .htaccess:

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ domain/$2 [L]
    RewriteRule . index.php [L]
    
    # END WordPress

    I replace my domain with "domain" in the .htaccess.

    TIA!

    Marc

  4. But if I read that wordpress creates the subdirs self, I expected problems on my managed server. So I decided to use subdirs.

    No. WordPress does not 'create' anything, it's all virtual. If you're making manual subfolders for your subsites, delete them now.

    What do you see at http://domain.de/test/ ?

    What does the 404 look like? Does it match your server or does it look like WP?

  5. Realtime64
    Member
    Posted 7 months ago #

    Hi!

    Oh ... I thought, I had read anything about server capabilities that are required for the subdir functionality.

    I don't create any folders in the wp dir.

    The server says:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@85.214.94.51 and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Are there any php settings that are required by wordpress? The ISP offers to install WP (an old version, no MultiSide) on my server via the control panel of the server. Maybe I should try to install this version, made a MultiSide an upgrade to 3.8?

    All the blogs working fine ... expect of the login in the meta-widget. Also, I got in one blog the same error message after I change the layout. But I expect, that the comes no error message if the login error is fixed

    If this is the only opinion, I would look if I could change the meta-widget. But I thing that this is not the best idea (updates / the error with the layout).

    Marc

  6. Okay, that error is NOT WORDPRESS. If the error isn't formatted like the rest of the site, then the issue is that you're not even getting to WP :)

    Go into your httpd.conf file and check if Allowoverride is set to either All or Options All

  7. Realtime64
    Member
    Posted 7 months ago #

    Hi!

    Many thanks for your help. I look into my server settings, but there is no "AllowOverride" option. The httpd.conf file also could't be edited, because this is an managed server.

    I contact the technical support to ask which settings are in the httpd.conf file and if is possible to set "AllowOverride Options All".

    I wrote here the result.

    Marc

  8. Hi Marc, I'm surprised your host blocks access to edit service config files. Usually when it's managed that just means that they provide some level of technical assistance.

    The default value of "AllowOverride" is "AllowOverride ALL" as mentioned in the docs. It's worth changing but if it doesn't work check your error log. The error log is probably the best tool to find out what's going on. If you don't know where the error log is located and have SSH access you could run the grep below. That will return the location of the log.

    grep ErrorLog /etc/httpd/conf/httpd.conf

    Since it's a managed service your host should be able to take it from there :).

  9. Realtime64
    Member
    Posted 7 months ago #

    Hi Patrick!

    No, the "Managed Server" means that my hoster ensure the functionality of my server. For example: I couldn't install no software on the server. This is very "funny" because I couldn't install the remote debugging tools for PHP for example.

    OK, BBT:

    I look into the /etc/httpd/conf/httpd.conf file. The settings are:

    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>

    Funny, or?

    If I set
    AllowOverride Options All
    I got an
    "Permission denied"
    if I want to save the settings.

    ... as I expected ... :-(

    If I call via browser

    http://domain.de/test/wp-login.php

    I got an

    [Sun Dec 22 21:31:49 2013] [error] [client IP_of_my_ISP] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
    [Sun Dec 22 21:31:49 2013] [error] [client IP_of_my_ISP] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
    [Sun Dec 22 21:31:49 2013] [error] [client IP_of_my_ISP] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

    Marc

  10. Did your host respond to your request to change to "AllowOverride Options All" ? I'm fairly confident that once you get that setting changed, and have the correct code in .htaccess, everything should work well!

    Essentially the "AllowOverride None" disables .htaccess from being loaded.

  11. Realtime64
    Member
    Posted 7 months ago #

    Hi Patrick!

    No, Strato didn't respond yet. I also thought, that they don't change the settings because they have thousends of identical servers.

    I read this with the AllowOverride None ... but the hoster put the setting of a protection of directorys in the .htaccess ...

    Edit/Add: I remember that in several directories I create a .htaccess with an AddDefaultCharset ISO-8859-1 in it an ... it works fine!

    We will see what Strato says ...

    Marc

  12. Realtime64
    Member
    Posted 7 months ago #

    Hi!

    Strato has answerd: It is not possible to change configurations of the managed servers induvidaly. The configurations would be optimized for security, stability and compatibility with other software. The server only could use "as it".

    I ask Strato which of the settings are not work. And if Strato know that a software like WordPress not work with all options on their servers.

    ... I thing I know the answer ...

    Many thanks for your support! I wait for the answer of Strato an will wort the answere here. Than I must thing how I change WordPress (Meta-widget, some designs) that WordPress is running on my server.

    Marc

  13. Well it's quite rare that a host denies you the ability to work with .htaccess. It's such an important file in Apache that you should consider another hosting provider. Chance are some things will never work quite right on your website. Maybe check out a WordPress recommend hosting provider?

  14. Realtime64
    Member
    Posted 7 months ago #

    Hi Patrick!

    I got the next message. A technical analyze my .htaccess and wrote me, that my .htacces should be working. He also told me that WordPress should be working fine. Now he want more information what's the problem should be.

    I also don't think that the .htaccess file won't work. For example: The AddDefaultCharset ISO-8859-1 works fine.

    Maybe in the next days we found a solution ...

    Marc

  15. Your .htaccess is fine.

    If they can't set AllowOverride to All or Options All, then the odds are Multisite will NEVER work on this host.

    Show them this: http://codex.wordpress.org/Multisite_Network_Administration#Apache_Virtual_Hosts_and_Mod_Rewrite

  16. Realtime64
    Member
    Posted 6 months ago #

    Hi!

    I resolved the problem ... :-)

    With this post and the delete of the "domain" in the .htaccess, it works.

    Start with code I should im add the .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) DOMAIN/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ DOMAIN/$2 [L]
    RewriteRule . index.php [L]

    Then delete the DOMAIN and add an RewriteRule ^([_0-9a-zA-Z-]+/)??les/(.+) wp-includes/ms-?les.php??le=$2 [L] I got this .htaccess:

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded ?les
    RewriteRule ^([_0-9a-zA-Z-]+/)??les/(.+) wp-includes/ms-?les.php??le=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    # END WordPress
    .

    This works fine!!!

    Thanks for your help! And ... the STRATO Managed Servers will work with this settings above!

    Marc

Reply

You must log in to post.

About this Topic