WordPress.org

Ready to get started?Download WordPress

Forums

Multisite Language Switcher
[resolved] Multisite Language Switcher works only when logged in (5 posts)

  1. thenouf007
    Member
    Posted 7 months ago #

    Hello,

    I have a multisite runnig 2 sites, one in Czech and one in english, I use
    if ( function_exists( 'the_msls' ) ) the_msls(); to show flags and descriptions. Works perfect when logged in and deaspear completely when logged out. Nothing is visible when I look at the source of the page. It happens on my localhost and the live server. Strangely I use it on another multisite system and there is no problem. What could be the problem? Thanks for your answer.

    http://wordpress.org/plugins/multisite-language-switcher/

  2. thenouf007
    Member
    Posted 7 months ago #

    Hello,

    I really need an answer! I've done all possible to try to make it work. I 've disabled all plugins and reviewed all the site functions. The the_msls(); is not recognized when logged out. And I can't go to WPML, it's a much too heavy plugin. Please, help. Thanks.

  3. realloc
    Member
    Plugin Author

    Posted 7 months ago #

    Sorry. I was out of the office for some days.

    Do you use a Cache-Plugin in this website?

  4. thenouf007
    Member
    Posted 7 months ago #

    No problem, thanks for your answer. I've solved the problem. I had a function permitting editors to add users just like admins. I've removed it and it works fine now. Sorry to have been a bit insisting.

  5. realloc
    Member
    Plugin Author

    Posted 7 months ago #

    OK, very good.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.