WordPress.org

Ready to get started?Download WordPress

Forums

Multisite install on Snow Leopard not working (11 posts)

  1. thefonso
    Member
    Posted 3 years ago #

    Ok, I have a multisite install set up on my Mac running Snow Leopard 10.6.4. I'm doing this as localhost and using sub-directories. I want to test this locally before I try it on clients isp.

    I have followed the instruction located here (http://codex.wordpress.org/Create_A_Network) to the letter.

    When I go to SuperAdmin/sites/Add Site and add a site everything works fine. I receive my username and password via email. But when I try to view the new site I get nothing.

    What am I doing wrong?

  2. Damien Saunders
    Member
    Posted 3 years ago #

    Hi there

    you say you received the email to confirm your new website, and you received the 2nd email with the u/name and password?

    So you should be trying to go to a url like this:

    localhost:8800/multisitename/newsubsitename/wp-admin

    but maybe try watching what happens to see if the URL changes from
    localhost:8800/multisitename/newsubsitename/wp-admin

    to

    localhost:8800/multisitename/wp-admin

    or make sure you logged out from the superadmin account /multisitename/wp-admin

    Damien

  3. You cannot run it on localhost with the port number int he URL .that;s why you can;t see the blogs. It's got nothing to do with if you got the email or not.

    If you put in your own admin email, you use the same username and password anyway.....

    Set up a fake domain name in your local hosts file. install WP in that.

  4. thefonso
    Member
    Posted 3 years ago #

    Oh this is PAINFULL. I've spent the whole week doing this. :(

    I've tried http://wpcandy.com/teaches/how-to-install-wordpress-locally-on-a-mac.
    That helped with putting a fake name in my host file so now I have "thefonso.com" on my local machine but as for setting up a second site under multisite...

    No joy. I get the super admin screen and can go throught the motions of creating another site but when I click "Visit"...No joy.

    Here is a look at my wp-config.php (maybe it will help)......

    [wp-config.php file removed by moderator. You just posted your complete wp-config.php file, including your database username and password, on a public forum. Change your passwords now!]

  5. (note to previous mod - it's his local install. ;) )

    @thefonso - what format did you pick? If you picked subdomains, they will not work locally because wildcard subdomains just do not work locally. you don't have dns records for your local domain. ;)

    If it's subfolder - dude, set up mod_rewrite like the instructions said.

  6. thefonso
    Member
    Posted 3 years ago #

    Format is subfolder. mod_rewrite....you mean loadmodule inside httpd.conf and then...

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    Order deny,allow
    Allow from all
    </Directory>

  7. thefonso
    Member
    Posted 3 years ago #

    THIS IS ON A LOCALHOST

    Here is the .htaccess file...

    RewriteEngine On
    RewriteBase /~gideon/wordpress/
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

  8. thefonso
    Member
    Posted 3 years ago #

    THIS IS ON A LOCALHOST
    Here is the wp-config.php file.....

    <?php
    /**
    * The base configurations of the WordPress.
    *
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information
    * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    *
    * This file is used by the wp-config.php creation script during the
    * installation. You don't have to use the web site, you can just copy this file
    * to "wp-config.php" and fill in the values.
    *
    * @package WordPress
    */

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'althea_db');

    /** MySQL database username */
    define('DB_USER', 'althea_wp');

    /** MySQL database password */
    define('DB_PASSWORD', 'helppeople');

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    /**#@+
    * Authentication Unique Keys and Salts.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define('AUTH_KEY', 'Et|wmU>9QgBHg3 x[+u/ZWj&cBEzg]Zgt=HG-V}Al_nXV~{4My}Gl|7J{Xj--GP7');
    define('SECURE_AUTH_KEY', '~1=kc0$-%id}O0h%C@4qt&w|{p2rGT9rKiv,m,7d_/1qVY)}OD_d;CTb+.crAV');
    define('LOGGED_IN_KEY', 'M|tR.8T&pu r|h|<:xDuCO-2,|3^u(+7k?e6YV>yKRy#}-jn,,NozGA{|l9l:WX3');
    define('NONCE_KEY', '<v4D|#17DUSW9Vzq;*@kQ|4LYEyIu$#2|C &u_ldN,6c8,^5bqmtz$?Alh0|UyEN');
    define('AUTH_SALT', 'l8!<:!k#XqtyfIr{?z:bso&U-fIn[a,t*m3t!*E2 ;|<-NESZZ?NQca$%/*r-nST');
    define('SECURE_AUTH_SALT', '9h#l62(LGZ#>bw|JZ6o}PmqowL*lD6xog{G9;,an1{]L)L-.K@-wsW|h7M#;.8');
    define('LOGGED_IN_SALT', 'qxuD=U+vy-o}uoS1O|y|GgYn+.MCWI+^*gZeN*Xu}+IA5)hkJvGmR#^-)}8>Ev');
    define('NONCE_SALT', '/G!IJhR;*_+^P.K$a@*jyo~FDj(sVK(~mTB0?$fplWC~Xj7S1U}N1~cw1GO5K</j');

    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = 'wp_blog';

    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
    * language support.
    */
    define ('WPLANG', '');

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);

    define('WP_ALLOW_MULTISITE', true);

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/~gideon/wordpress/';
    define( 'DOMAIN_CURRENT_SITE', 'thefonso.com' );
    define( 'PATH_CURRENT_SITE', '/~gideon/wordpress/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

  9. We still don;t need to see your WHOLE config file. :P

    We just needed to see the multisite defines and the htaccess fiel.

    this bit:

    define( 'SUBDOMAIN_INSTALL', false );

    says you;re using subfolders.

    Do pretty permalinks works? Yes or no?

    This bit:

    define( 'PATH_CURRENT_SITE', '/~gideon/wordpress/' );

    Are you using the method of putting wordpress inthe /wordpress./ folder and trying to server it from /~gideon/" ?

    Also, if you're installing it locally at thefonso.com,. then that shouldn't even BE there. It should just be "/"

    Did you tell your local box that thefonso.com is that doc root?

  10. thefonso
    Member
    Posted 3 years ago #

    "Did you tell your local box that thefonso.com is the doc root?"

    negative.

    .....(time passes as I attend to doc root in httpd.conf)

    THAT'S IT!!!

    Andrea_r you're priceless. Thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic