WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Multisite cant login to super admin (43 posts)

  1. fearRacious
    Member
    Posted 1 year ago #

    Hey guys,

    I have switched my website from a 209.105.244.10 to http://www.drheatherlariviere.com/ but and it worked good..Just when I login at firefox it wont let me instead go to the homepage.But in Chrome it worked and it lets me login.But when I try to go to the super admin to add plugins it wont let me login..

    Can anyone help me??

    Thank you

  2. fearRacious
    Member
    Posted 1 year ago #

    Hey, Thank you for the reply..I actually done that..That was my first step when I was switching it.It worked now and I can also get to the admin BUT not in the network admin.It just redirect me to a login form and I cant login back...

  3. fearRacious
    Member
    Posted 1 year ago #

    here is my .htaccess files

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    and here is the wp-config

    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'drheatherlariviere.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', '');
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');

    /* That's all, stop editing! Happy blogging. */

  4. Are you absolutely sure you're logged in as the super admin?

    Go into wp_sitemeta and look for site_admins.

    In there you will see something like this: a:1:{i:0;s:7:"Ipstenu";}

    If your userID is ‘fearRacious’ then it would be a:1:{i:0;s:11:"fearRacious";}

  5. fearRacious
    Member
    Posted 1 year ago #

    yes...

    here is my site_admins is a:1:{i:0;s:12:"drheater5432";}

  6. fearRacious
    Member
    Posted 1 year ago #

    Do I have to change on the site_admins??

  7. fearRacious
    Member
    Posted 1 year ago #

    Also,when I changed my permalink.The other links are not working so now im using the default permalink..

    Am I doing something wrong on the Database and wp-config and htaccess??

  8. Do I have to change on the site_admins??

    No. That wasn't the point. The point was to VERIFY you were the admin. If you're logged in as drheater5432 you should be fine.

    Try deleting all your cookies for the old and new blog URL.

  9. fearRacious
    Member
    Posted 1 year ago #

    Try deleting all your cookies for the old and new blog URL.

    Wait,how to do that..I did with my ccleaner and clean my pc and browser..But didnt work..

  10. fearRacious
    Member
    Posted 1 year ago #

    I did try clearing my browser cookies at chrome but going to super admin It wont log me in..When I do like http://www.drheatherlariviere.com/wp-admin and put the username and password it worked,and I can log in successfully..

    When I try clicking to the super admin it just log me out and need to enter the username and password again..

    Is there something wrong on the installation??

  11. fearRacious
    Member
    Posted 1 year ago #

    Is there any wrong with my htaccess or wp-config??also my permalink not working when I set to default.Now I have to put it at default..

    Anyone???

  12. fearRacious
    Member
    Posted 1 year ago #

    I was testing the link that I have when I login to the http://www.drheatherlariviere.com/wp-admin it gives me this link
    (http://www.drheatherlariviere.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.drheatherlariviere.com%2Fwp-admin%2Fnetwork%2F&reauth=1)

    And when I try to go to super admin this is the link it show (http://www.drheatherlariviere.com/wp-login.php?redirect_to=http%3A%2F%2Fdrheatherlariviere.com%2Fwp-admin%2F&reauth=1)

    and I notice that in the http%3A%2F%2Fdrheatherlariviere.com theres no www. so I added it and I finally login to the wordpress network admin..

    So,if Im not wrong that might be the problem so how can I get that fixed??

    thank you.

  13. Be calm and don't bump your posts needlessly.

    The forums are staffed 100% by volunteers, all of whom have jobs. If you need to have something fixed that fast, you hire someone from jobs.wordpress.net - otherwise, you wait and hope someone sees this and can fix it.

    Interesting that your site is using www when the wp-config clearly says it shouldn't be:

    define('DOMAIN_CURRENT_SITE', 'drheatherlariviere.com');

    Does your webhost force in the www? You may need to search/replace and add that in, though I'd hate to do that :/ Basically something on your server is forcing in www. You may want to ask your host about it.

  14. fearRacious
    Member
    Posted 1 year ago #

    Thanks Ipstenu..

    By you mean of search and replace..Do you mean the wordpress plugin that I have to search and replace or to the Database..Or should I go to my database and look for that??

    "Does your webhost force in the www? You may need to search/replace and add that in, though I'd hate to do that :/ Basically something on your server is forcing in www. You may want to ask your host about it."

    I dont get you on this...So, I should ask our hosting provider if they require a http://www.??

  15. When you moved your site, did you search for the IP and replace with www. drheatherlariviere.com or JUST drheatherlariviere.com?

  16. fearRacious
    Member
    Posted 1 year ago #

    Hello,

    no I didnt just directly with the drheatherlariviere.com..

  17. Lorraine
    Member
    Posted 1 year ago #

    Hi there, I am having this exact issue going from an ipaddress on a test server. You can access network admin but you will need to type the full address drheatherlariviere.com/wp-admin/network/ This will allow you to login. If you issues are identical to mine you will be able to enable permalink in your subsites, it's just the main that will have the issue.

  18. fearRacious
    Member
    Posted 1 year ago #

    Hello Lorraine,

    Thank you for the suggestions..I try it but it didnt work on mine..When I try to login it just reload and goes back to login form..

    Yes,subsites work with the custom permalink but main site wont work if I change the permalink..

  19. fearRacious
    Member
    Posted 1 year ago #

    This is what the server provider told me too..

    "As we can see, the redirection is cased in your wordpress configuration. I'm afraid that we do not support third party scripts, and we recommend you to contact your developer or official wordpress support about this issue."

  20. no I didnt just directly with the drheatherlariviere.com..

    I'm sorry, I'm not sure what you're trying to say here.

    When you moved your site, did you search for the IP and replace with www. drheatherlariviere.com or drheatherlariviere.com?

    You can just reply with the one you did the search/replace with :) 'no I didn't just' doesn't make any gramatical sense (I suspect you're ESL, because I can totally see how that makes sense in other languages).

  21. fearRacious
    Member
    Posted 1 year ago #

    AHAHAH...I did search and replace on the database like what is said on here http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Multisite

    but not with using the plugin search and replace.

  22. Right, what I'm asking is what did you use for the 'replace' string.

    i.e. "I search for the IP and replaced with ....'

    I need to know exactly what you used to replace :)

  23. fearRacious
    Member
    Posted 1 year ago #

    I used this one drheatherlariviere.com..

  24. Two things to do.

    1) Search your DB for www.drheatherlariviere.com and see if it's lurking. This also means check your wp_blogs and wp_sites tables to see if www is floating around there

    2) Check with your host to see if they're forcing www.

  25. fearRacious
    Member
    Posted 1 year ago #

    Thank you Ipstenu, Ill check my DB again and look it theres a www. on the tables, should I take out if there is??

    This is what the hosting told me when I ask if they used www.

    "As we can see, the redirection is cased in your wordpress configuration. I'm afraid that we do not support third party scripts, and we recommend you to contact your developer or official wordpress support about this issue."

  26. Dear Webhosts: Read the flipping questions. The question was not 'Why do I get http://www...' but 'Is there anything on your servers or DNS that forces www.'

    Grr. I DETEST when people don't read the question.

    Anyway. Since they're incompetent we'll have to figure out ourselves. If you go to http://drheatherlariviere.com/readme.html it does not redirect. So it's the DB.

    Ill check my DB again and look it theres a www. on the tables, should I take out if there is??

    For now, just see if it is and report back WHERE it is.

  27. fearRacious
    Member
    Posted 1 year ago #

  28. What are the ones in wp_sitemeta?

    That one and the wp_x_options tables are the ones you would want to look at HOWEVER the ones in _options may be serialized data, so take a look and see what they are first :)

  29. fearRacious
    Member
    Posted 1 year ago #

    This what it is on the wp_sitemeta value (http://www.drheatherlariviere.com/)

    and on the wp_options and wp_2_options site url and home I have this (http://www.drheatherlariviere.com/) and dashboard widget options is this (a:4:{s:25:"dashboard_recent_comments";a:1:{s:5:"items";i:5;}s:24:"dashboard_incoming_links";a:5:{s:4:"home";s:33:"http://www.drheatherlariviere.com";s:4:"link";s:109:"http://blogsearch.google.com/blogsearch?scoring=d&partner=wordpress&q=link:http://www.drheatherlariviere.com/";s:3:"url";s:140:"http://blogsearch.google.com/blogsearch_feeds?scoring=d&ie=utf-8&num=10&output=rss&partner=wordpress&q=link:http://209.105.244.10/~drheathe/";s:5:"items";i:10;s:9:"show_date";b:0;}s:17:"dashboard_primary";a:7:{s:4:"link";s:26:"http://wordpress.org/news/";s:3:"url";s:31:"http://wordpress.org/news/feed/";s:5:"title";s:14:"WordPress Blog";s:5:"items";i:2;s:12:"show_summary";i:1;s:11:"show_author";i:0;s:9:"show_date";i:1;}s:19:"dashboard_secondary";a:7:{s:4:"link";s:28:"http://planet.wordpress.org/";s:3:"url";s:33:"http://planet.wordpress.org/feed/";s:5:"title";s:20:"Other WordPress News";s:5:"items";i:5;s:12:"show_summary";i:0;s:11:"show_author";i:0;s:9:"show_date";i:0;}})

Topic Closed

This topic has been closed to new replies.

About this Topic