WordPress.org

Ready to get started?Download WordPress

Forums

Multisite blogs.dir / sites folder (4 posts)

  1. Morphim
    Member
    Posted 1 year ago #

    Hi there. I have a problem with my subfolder sites.
    The issue (amongst other things) is the use of TimThumb image processing embedded in a theme I use.
    The main site works fine but the sub sites won't show images.

    This is what the theme designer said when i mentioned the blogs.dir

    "Our theme works with MS as you can see in our demo. The reason it may not be for you is because of your file path which is from OLDER version of WP. In the older WP MS, it creates blogs.dir/files/…etc but in the newer version of WP MS, it doesn’t. In fact you won’t even see that folder if you’ve installed WP MS from scratch with the new version."

    This is the main part of one of his demo subfolder image paths (via timthumb)
    wp-content/uploads/sites/8/2012/04/portfolio-8.jpg

    this is mine
    lumenlamps/files/2013/03

    I have 'wp-content/uploads/' but not 'sites'
    My images are 'wp-content/blogs.dir/2/files/2013/03'

    I have the lateset verison of WordPress & theme plugins etc.
    What I want to know is, how to resolve this without a complete wipe & reinstall.
    Why isn't the newer file system in place after updating & is it possible to sort it out?
    I can obviously manually create these folders but how would I force WP to use them
    Any help gratefully received.

  2. If your images are pointing to lumenlamps/files/2013/03 then you DID start using WP Multisite on the older versions.

    Updating doesn't change that. You would have to do it manually. Or ... not use TimThumb.

    http://halfelf.org/2012/dumping-ms-files/

  3. Morphim
    Member
    Posted 1 year ago #

    Thanks very much for the reply, Mika.

    I took a look at your blog post regarding this issue ('bolluxing' is a good word ; )
    This file / folder path problem seems rather messy, which irks me. I'm thinking I might just re-install everything. Upon initial reading, I think your solution seems laden with potential problems & pitfalls when placed in my incapable, novice hands.
    I'll re-read it, try to focus then decide what to do.

    You mention this:

    Edit all sites

    Upload Path, Upload URL Path and Fileupload Url. You can blank them all out.

    ... but since I was doing the sites one at a time, I did them one at a time.

    Sorry to be dumb, but where is this done?

    Thanks again

    Gary

  4. Well .. how new is this site?

    If it's brand new, you'd be best off starting over with a clean 3.5 (or possibly install it all locally as 3.5, import the info, and then move it live).

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.