WordPress.org

Ready to get started?Download WordPress

Forums

User Role Editor
[resolved] Multisite: Apply to all sites only affects existing sites - new sites? (16 posts)

  1. askwpcoach
    Member
    Posted 11 months ago #

    Hello,

    When I make amendments to the Administrator role & apply to all sites. Only the existing sites receive the amendments, new sites use the default configuration.

    Is there any way to ensure all sites (including new) receive the amendments I set?

    Thanks for your time,

    http://wordpress.org/plugins/user-role-editor/

  2. Vladimir Garagulya
    Member
    Plugin Author

    Posted 11 months ago #

    Hello,

    New added site should get copy of roles from the main site of your network. Please double check, that changes made to the role at the main site do not appear at the same role of new site created after those changes made.

    Regards,
    Vladimir.

  3. askwpcoach
    Member
    Posted 11 months ago #

    I have checked and confirm - they are not copied to new sites.

    Thanks,
    Richard

  4. Vladimir Garagulya
    Member
    Plugin Author

    Posted 11 months ago #

    Hi Richard,

    Thanks. How is new blog added to your network? Is it standard "Network Admin"=>"Sites"=>"Add New" operation? Or do you use some plugin or custom piece of code for that?
    I have similar notice from one URE user. Roles are copied for new blog during standard WP procedure, but they are not copied for the custom action. As that action occurs before URE is load its own roles copy action - just after user login.

    Regards,
    Vladimir.

  5. askwpcoach
    Member
    Posted 11 months ago #

    Hello Valdimir,

    I am using Gravity Forms User Registration Addon: http://www.gravityforms.com/add-ons/user-registration/ - Sites are created when the user registers.

    Do you think this could be affecting it?

    Kind Regards,
    Richard

  6. Vladimir Garagulya
    Member
    Plugin Author

    Posted 11 months ago #

    Yes, I'm sure it is the similar case I wrote above.
    Could you please send this addon package to me (vladimir [at-symbol] shinephp.com) for evaluation and testing? I wish to hook some earlier WP action for roles copying.

    Regards,
    Vladimir.

  7. askwpcoach
    Member
    Posted 11 months ago #

    No problem, do you already have the Gravity Forms base plugin?

  8. askwpcoach
    Member
    Posted 11 months ago #

    Sent - please confirm you receive it.

    Thanks

  9. Vladimir Garagulya
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks. I got it.
    It seems that it works with GF v. 1.7.5 I have for testing. I will investigate the problem and try to search the decision.

  10. askwpcoach
    Member
    Posted 11 months ago #

    Thank you for your attention/assistance.

  11. Vladimir Garagulya
    Member
    Plugin Author

    Posted 11 months ago #

    Please try the updated beta version 4.2.1
    http://role-editor.com/downloads/user-role-editor-4.2.1-beta.zip
    It should copy main blog roles when new site is added from front-end too.

  12. askwpcoach
    Member
    Posted 11 months ago #

    Thanks - I will certainly try this when I return. I have to leave for a few hours.

    Thanks again for your attention / support.

    Kind Regards,
    Richard

  13. askwpcoach
    Member
    Posted 11 months ago #

    Thanks,

    It seems all is working now. I really appreciate your attention on this.

    Kind Regards,
    Richard

  14. Vladimir Garagulya
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks, Richard, for the feedback.

    Regards,
    Vladimir.

  15. trilliumcoast
    Member
    Posted 10 months ago #

    I am experiencing issues with the plugin in MU. It works fine on the primary site, however, the subsequent sites post errors. In addition, when viewing Users via Network Admin the option to add a user role upon user creation is now missing.

    Urgent assistance is appreciated.

      error example: (domain root removed)

    Warning: Invalid argument supplied for foreach() in /home/domain/public_html/wp-content/plugins/user-role-editor/includes/class-ure-lib.php on line 1319

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/tomthoms/public_html/wp-content/plugins/user-role-editor/includes/class-ure-lib.php on line 535

    Warning: array_pop() [function.array-pop]: The argument should be an array in /home/domain/public_html/wp-content/plugins/user-role-editor/includes/class-ure-lib.php on line 536

    Warning: Invalid argument supplied for foreach() in /home/domain/public_html/wp-content/plugins/user-role-editor/includes/class-ure-lib.php on line 2039

    Warning: Invalid argument supplied for foreach() in /home/domain/public_html/wp-content/plugins/user-role-editor/includes/class-ure-lib.php on line 794

    Warning: Invalid argument supplied for foreach() in /home/domain/public_html/wp-content/plugins/user-role-editor/includes/class-ure-lib.php on line 928

  16. Vladimir Garagulya
    Member
    Plugin Author

    Posted 10 months ago #

    Hi,

    Thanks for the information. Role assignment to the users under multi-site is made on the per site basis. As WP does not allow make it at Network Center directly under Users menu, URE goes the same way.
    But I plan to add such feature to the Pro version of plugin.

    Thanks for the information about error messages with URE. I could not help you now, as I'm at the holiday trip. If you will not resolve this issue until September, 20, I will try to help you definitely.

    Regards,
    Vladimir.

Reply

You must log in to post.

About this Plugin

About this Topic