WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Multisite: 404 permalinks issue (8 posts)

  1. sulfurito
    Member
    Posted 2 years ago #

    Hello, I'm setting up a multisite with subdomain option. So far it's working but I can't access pages when I use permalink option different than default (http://sub.site.com/?p=123). I've seen it's a common issue but so far any of the solutions reccomended (reset permalink config, put in Apache httpd.conf what I have in .htaccess) didn´t work for me.

    This is my .htaccess content:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    I just saw this sticky post now and didn't put it in practice yet, I'll go for it now but in the mean time I would appreciate other clues.

    Thank you very much

  2. wdisk
    Member
    Posted 2 years ago #

    Check your Apache installation, does it compile with mod_rewrite
    http://httpd.apache.org/docs/2.2/mod/mod_rewrite.html

  3. sulfurito
    Member
    Posted 2 years ago #

    I think so, this is in my httpd.conf:ç

    http://ordinateur-portable.france-abonnements.com/ordinateur-portable.asp

    Thank you

  4. wdisk
    Member
    Posted 2 years ago #

    I don't know your link page language

    there is an easy way to find out:

    1)create a phpinfo.php in your site-root, put a line code in it:
    <?php phpinfo()?>
    2)view it in your IE or chrome e.g. http://yoursite.com/phpinfo.php
    find: apache2handler Loaded Modules

    3)check if there is "mod_rewrite" in that line

  5. Just a note - your htaccess content does not matter if Apache is not reading it or if mod_rewrite is not enabled. ;)

    If you are not sure if you have mod_rewrite, ask your webhost.

  6. sulfurito
    Member
    Posted 2 years ago #

    Ooops sorry, wrong clipboard content, THIS is my httpd.conf:

    LoadModule rewrite_module modules/mod_rewrite.so

    And yes, I can see it in phpinfo()

  7. Is AllowOverride set to All in that httpd.conf? My french isn't good enough to parse.

  8. sulfurito
    Member
    Posted 2 years ago #

    Is AllowOverride set to All in that httpd.conf? My french isn't good enough to parse

    It wasn't, now it is and it works.

    Thank you very much

Topic Closed

This topic has been closed to new replies.

About this Topic