WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Multisite, 1and1 and 404 messages (8 posts)

  1. RF9series2
    Member
    Posted 2 years ago #

    Hello,

    I hope some one can help me with this. I have 1and1 web hosting and a quick trip through the forums have shown me that 1and1 and wordpress have a pretty sketchy relationship.

    Anyway, I am trying to run a multisite through wordpress on my domain,

    http://www.stuntsproductions.com

    I have gotten everything running and after a few days of adding files and plugins the site will work fine until *poof!* it just stops. I can access my main homepage, I can even login and see my main site and multisite dashboards, but everything else sends me to the 1and1 404 page. This is the third time this has happened and my only fix so far has been to uninstall and reinstall everything.

    I have tried modifying my .htaccess and have deleted all of my plugins, but nothing has returned. I have even contacted 1and1 tech support and maybe I'm not specifying my problem well enough because they have only sent me replies that confirm that my site is indeed not working.

    Please let me know what I can do to resolve this issue without having to reinstall my site again.

  2. Failed opening '/homepages/12/d374024884/htdocs//wp-content/plugins/featured-content-gallery/gallery.php' for inclusion (include_path='.:/usr/lib/php5') in /homepages/12/d374024884/htdocs/wp-content/themes/comicpress/index.php on line 20

    Switch to a default theme, TwentyEleven, and see if that helps.

    Your theme may require ComicPress.

  3. RF9series2
    Member
    Posted 2 years ago #

    I have just switched my theme to TwentyEleven, there is no change.

  4. What's in your .htaccess?

  5. RF9series2
    Member
    Posted 2 years ago #

    AddType x-mapp-php5 .php
    Action x-mapp-php3 /system-bin/php6exe
    Action x-mapp-php4 /system-bin/php6exe

    Before it was only the last two lines. If I add the rest of the code that I have seen for the .htaccess then my whole site goes down with a 500 error page.

  6. Well...

    That's the problem right there. WP needs that code. Won't work without it. Go ask your host if:

    1) Mod_Rewrite is on
    2) AllowOverride is set to ALL

  7. RF9series2
    Member
    Posted 2 years ago #

    Thank you for your help, I just shot 1and1 support an email with that in it to see what they can do. I will keep ya posted. : )

  8. RF9series2
    Member
    Posted 2 years ago #

    So to give an update, since I had to turn in a final for my web class I could not wait for 1and1 to help fix my issue but I did ask them about the mod_rewrite info and they sent this to me...

    Thank you for contacting us.

    We would like to inform you that Mod_Rewrite is already on to the server and AllowOverride is not available on shared hosting package only on a server package. And regarding with your previous concern about the pages of your wordpress site that is just about the siteurl of your website but as per checking it is already fix. Thank you.

    If you have any further questions please do not hesitate to contact us.

    The reason my site was fixed is because I uninstalled and reinstalled wordpress myself.

    I think the issue stands from using a multisite and different themes since I was trying to use comicpress to start a webcomic and another theme for my web class. When I use one or the other my site runs just fine, so I think I I'll rebuild my site once my final grade is posted.

Topic Closed

This topic has been closed to new replies.

About this Topic