WordPress.org

Ready to get started?Download WordPress

Forums

Multiple WordPresses cause trouble logging in? (10 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    Hi there,
    I've installed WP on two separate place on my domain. One version is meant for news (http://www.thecreativestylus.net) and works just fine, while the other is meant as my personal journal and, upon installation, will not allow me to log in. It would be located, if I ever get it to work, http://www.thecreativestylus.net/journal. Does anyone know why one WP install might work and the other one refuses to log me in? It simply refreshes the page each time I try. I've chmoded the weblogs.cach file and made sure the password is correct, and it totally refuses. Help is greatly appreciated!
    Jessica

  2. Dougal Campbell
    Member
    Posted 10 years ago #

    I've run into this problem with my test install. I think it's an issue with the login cookies for two installations clashing. I'll be looking into it soon, and hope to get some fixes in Real Soon Now.
    If you aren't afraid of digging into the PHP source, you might try locating all of the setcookie() calls and adding a path parameter. If you don't know what in the world that means, then just wait for the patches :)

  3. southerngal
    Member
    Posted 10 years ago #

    Any news on the patches?

  4. Dougal Campbell
    Member
    Posted 10 years ago #

    Yes, I put in some patches a few days ago to deal with that problem. It's in CVS :)

  5. southerngal
    Member
    Posted 10 years ago #

    Great thanks! Sending you an email, because I am a person who doesn't understand CVS all that well. :)

  6. southerngal
    Member
    Posted 10 years ago #

    I went and applied the patches, still not working. :(

  7. southerngal
    Member
    Posted 10 years ago #

    Now I get this:
    Since you’re a newcomer, you’ll have to wait for an admin to raise your level to 1, in order to be authorized to post.
    You can also e-mail the admin to ask for a promotion.
    When you’re promoted, just reload this page and you’ll be able to blog. :)
    I'm not a newcomer! I will have to uninstall and reinstall the entire blog.

  8. southerngal
    Member
    Posted 10 years ago #

    I solved the entire problem by deleting the second blog and then reinstalling it using Opera. It's the only browser out of Mozilla, IE 6 and Opera that will let me log in to the second blog. It will not let me log into the first blog. I have to use 2 separate browsers to get to 2 blogs.
    When a new release is developed, please address this! Thanks! :)

  9. southerngal
    Member
    Posted 10 years ago #

    *bumping* this up so that Matt and Mike can see this post as well. :)

  10. OperaManiac
    Member
    Posted 10 years ago #

    mate is the cookie problem solved? i would like a patch of sort. :|

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.