WordPress.org

Ready to get started?Download WordPress

Forums

Feed Them Social
[resolved] Multiple Undefined Property Errors (13 posts)

  1. seanocaside21
    Member
    Posted 6 months ago #

    Hi I have recently purchased the premium version of feed them social and when i insert the shortcode i am presented with a bunch of warning text:

    For example:

    Notice: Undefined property: stdClass::$comments in /usr/local/pem/vhosts/132112/webspace/httpdocs/wp-content/plugins/feed-them-social/feeds/facebook/facebook-feed.php on line 109

    Any help in fixing this?

    https://wordpress.org/plugins/feed-them-social/

  2. slickremix
    Member
    Plugin Author

    Posted 6 months ago #

    Thanks for contacting us. Is this a local install on your computer, or an actual server?

    If it is local, the facebook feed will not work properly. Feed Them Social will only work properly if on a live server.

  3. seanocaside21
    Member
    Posted 6 months ago #

    Its an actual server!

    You can view the page here... i have just added the Facebook shortcode again so you can see what happening.

    http://internetcollege.ie/

  4. slickremix
    Member
    Plugin Author

    Posted 6 months ago #

    Cool! When I view the page the feed is working and looking great. Where are you seeing this message appear?

  5. seanocaside21
    Member
    Posted 6 months ago #

    I deactivated and then reactivated all my plugins and it seems to be working fine!

    Ill keep you posted if the problem occurs again.

    Thanks for coming back to me so quickly!

  6. seanocaside21
    Member
    Posted 6 months ago #

    Oh, while i have you....

    Is there anyway to disable showing the Facebook image post?

  7. slickremix
    Member
    Plugin Author

    Posted 6 months ago #

    You can always use our custom CSS box to target or change things you want on our feed.

    For instance if you don't want to see the general images or video images in a facebook feed you would add something like this to the custom CSS box on the settings page of our plugin.

    a.fts-jal-fb-picture, .fts-jal-fb-vid-picture {
    	display:none;
    }

    If you would not mind leaving a review that would be awesome!
    https://wordpress.org/support/view/plugin-reviews/feed-them-social?filter=5

  8. seanocaside21
    Member
    Posted 5 months ago #

    Hi Again,

    The problem seems to be back again! More of the same:

    Notice: Undefined property: stdClass::$story in /usr/local/pem/vhosts/132112/webspace/httpdocs/wp-content/plugins/feed-them-social/feeds/facebook/facebook-feed.php on line 181

    You can take a look here http://internetcollege.ie/category/news/

    Thanks

  9. slickremix
    Member
    Plugin Author

    Posted 5 months ago #

    Do you have wp_debug mode on in your wp-config.php file?

  10. slickremix
    Member
    Plugin Author

    Posted 5 months ago #

    Go to the feed them social system info page and look at the bottom and see if it is on.

  11. seanocaside21
    Member
    Posted 5 months ago #

    Yep i have it on... was left on from something i was doing before.

    Should i turn it off?

  12. slickremix
    Member
    Plugin Author

    Posted 5 months ago #

    Yes, debug mode should only be on if you are doing developing testing.

  13. seanocaside21
    Member
    Posted 5 months ago #

    Thanks for the help!!

Reply

You must log in to post.

About this Plugin

About this Topic