WordPress.org

Ready to get started?Download WordPress

Forums

Vantage
[resolved] multilingual home page (13 posts)

  1. Doe3
    Member
    Posted 9 months ago #

    Hi,
    I ran into some trouble with making my home page multilingual. I've been using WPML with other websites, but haven't used it with page builder before. Do you have a recommendation for this? Another language plugin? I know other themes with page builder using WPML. I just don't know where to start looking for the solution.
    (I was able to translate everything else, like pages, posts, strings, etc.)
    Thank you!

  2. Greg Priday
    Member
    Theme Author

    Posted 9 months ago #

    I haven't tested this myself with WPML, but the best option might be to disable the custom home page (Appearance > Home Page). Then to create a new standard page as the home page, and assign that to your front page in your reading settings (Settings > Reading).

    Then, using WPML, you could create the multi lingual versions of this page.

    The latest version of Page Builder (1.3.7), lets you clone the current custom home page, so this should help with the transition.

  3. Doe3
    Member
    Posted 9 months ago #

    Thanks Greg. That sounds workable. :)

  4. Doe3
    Member
    Posted 9 months ago #

    Hi Greg,
    I started implementing your suggestion. Created a new page, cloned the Home page layout and added the Meta slider widget. However on this page the slider's layout is different as there is a gap between the menu and the slider and it's not wide like the custom home page.
    Here's a screenshot (it's still just a draft page): http://awesomescreenshot.com/06f1sm8se4

  5. Doe3
    Member
    Posted 9 months ago #

    I think I got it now.

  6. Greg Priday
    Member
    Theme Author

    Posted 9 months ago #

    Yeah, once you set the new home page, the Meta Slider will show up. For sub pages, you can also use the Meta Slider option to get a big slider that looks like the home page slider.

  7. Doe3
    Member
    Posted 9 months ago #

    Hats off to you Greg! Excellent support! :)

  8. Doe3
    Member
    Posted 9 months ago #

    Hi,
    I have one more thing for the English home page. I created an English version of the slider, but when I choose that on the English homepage I get two sliders showing up: the Hungarian with the proper layout, identical to the Hungarian home page and the English one right under it, but not wide (kind of like in the screenshot above).
    How could I make this work?
    Thank you.

  9. Doe3
    Member
    Posted 8 months ago #

    Hi Greg,
    I updated the theme as well as Meta Slider and I still can't get the English homepage to have the English slides only. If I change the slider to show the English slides on the English version of the Home Page, there are still two sliders showing up. The Hungarian on top and the English underneath. Like this: http://awesomescreenshot.com/07b1ukl7bc
    How could I fix this?

  10. Matcha Labs
    Member
    Posted 8 months ago #

    Hi Doe3/Greg,

    Not sure if it helps, but I made some changes to the latest version of Meta Slider for WPML. Previously, it only seemed to work in the default language, in other languages the slideshow would be blank.

    Now, a Meta Slider slideshow will always look the same no matter which language you're viewing the page in.

    If you have 2 languages and you need a slideshow to display differently in each language, then you must create 2 separate slideshows (one for each language) and update the shortcode on your translated pages accordingly.

    Not sure if that sheds any light on this..

    Regards,
    Tom

  11. Doe3
    Member
    Posted 8 months ago #

    Thanks Tom.
    The thing is that I'm using page builder and I have a separate home page for both languages where I can set each element separately.
    The problem is that when I choose the English slide for the English home page, both the Hungarian and the English show up. :(

  12. Matcha Labs
    Member
    Posted 8 months ago #

    I could be wrong, but it looks like that top slider is the one that is set up in the theme settings (for the homepage slider) and the bottom one is the one from page builder.

    In the theme settings for the homepage slider I would set it to 'no slider' (or whatever the option is), then just use page builder for each translated page to select the slider.... (I'm out of my depth here as I'm not 100% sure how page builder or vantage works - but it's something to try until Greg replies :))

    Regards,
    Tom.

  13. Doe3
    Member
    Posted 8 months ago #

    You're probably right.
    I still hope though that there is another solution as the homepage slider fits nicer with the theme, as you can see in the screen shot.
    Thanks again. :)

Reply

You must log in to post.

About this Theme

About this Topic