WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Multi-site with subdomains - v4 upgrade issues (11 posts)

  1. magicroundabout
    Member
    Posted 2 years ago #

    Hi Marcus,

    I don't know if this is a similar issue to dokauai's in the forum below.

    I've got a multisite setup with subdomains and domain mapping running on WP 3.1.3. I've been using Event Manager for a good few months and it's been fine. Note that I'm only using EM on some sub-sites, not on the mainl site, so it's not network enabled.

    After a successful upgrade on a standalone (i.e. non-multisite) install I had a go at this multisite and it's failed.

    The upgrade is from EM v3.0.97 to 4.0.6

    Initially I got a red banner in the Dashboard saying “Events Manager upgrade not complete, please upgrade to version 3.0.96 or higher first from here first before upgrading to this version. We made a screencast to help you out.”. My events also disappeared from the EM dashboard and from the website - I'm sure they're in the database, but I can't see them.

    I then saw your screencast and discovered the database upgrade trigger problem. A de-activate and re-activate of the plugin (at sub-site level) didn't help and the options.php showed dbem_version 3.0.95.

    SO...I downgraded to v3.0.98, did the de-activate and re-activate and everything was OK again. I then re-did the upgrade to 4.0.6, followed by a de-activate and re-activate. I'm in a slightly better place: there's no red banner message on the Dashboard, but I still can't see any events.

    I've just tried a downgrade to v4.0.4 as you suggested to someone else but I'm still in the same state.

    Any thoughts on how to get my events to display again?

    Thanks

    Ross Wintle

  2. garethsprice
    Member
    Posted 2 years ago #

    This happened to me too. There's a screencast at http://wp-events-plugin.com/news/upgrade-issues-screencast-walkthrough/ but that did not work for me - my event listing page still read "no events".

    Edit: Tried downgrading to 3.0.98, events displayed but could not save as it threw an error.

    Investigated further, could create new events and they would show up.

    Looked into the database and found that my v3 events did not have the blog_id column set. Ran "UPDATE wp_11_em_events SET blog_id=11" in MySQL to set the blog_id and events now show up.

    Seems redundant to have the blog_id set as it can be determined from the table name or WordPress API??

  3. magicroundabout
    Member
    Posted 2 years ago #

    Good work Gareth - I'll give that a go!

    Marcus, can we get this fixed? It's obviously something the database update script needs to check?

    Thanks

  4. magicroundabout
    Member
    Posted 2 years ago #

    Well, OK this has sort-of worked. I've got my events back, but the "scope" isn't quite working - it's displaying past events where it shouldn't be.

    I dived into the code and it looks like it should be constructing a condition:

    elseif ($scope == "future"){
    $conditions['scope'] = " event_start_date >= CAST('$today' AS DATE)";

    But this obviously isn't happening (I'll try to do some debugging).

    Oddly, my widget now seems to have both a "Scope of the Events" and a "Scope" option - related?

  5. magicroundabout
    Member
    Posted 2 years ago #

    Further investigation:

    I was using v4.0.4 of the plugin - I'm now back to 4.0.6 and the duplicate scope field in the widget settings has disappeared, but it's not saving the scope setting, or obeying it in queries - i.e. I'm still seeing past events in event lists (in both pages and widgets!)

  6. magicroundabout
    Member
    Posted 2 years ago #

    Just tried dev version of 4.0.7 and it's still ignoring the "Scope" in the queries and displaying all events instead of future events.

  7. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    a few people have this issue, they all seem to have the same issue which is an older version of wp, particularly 3.0.5, updating fixed it

  8. magicroundabout
    Member
    Posted 2 years ago #

    Well, I was running on WP3.1.3 but I upgraded EM to 3.0.8 yesterday and that seems to have fixed it.

    Thanks for all the hard work getting v4 out and working. Amazing plugin! :-)

  9. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    glad to hear. btw, the minimum requirement is 3.1, due to some javascript updates. you might want to check the booking forms specifically

  10. albertopoku
    Member
    Posted 2 years ago #

    Loads of thanks you garethsprice and magicroundabout, you guy just saved my job!!!! I use multi-sites, I upgraded wp to 3.2 and then I could not view the events.

    I followed the screencast at http://wp-events-plugin.com/news/upgrade-issues-screencast-walkthrough/ and upgraded em to 4.0.9 but my event listing page still read "no events".

    After running "UPDATE wp_21_em_events SET blog_id=21" in MySQL to set the blog_id, the events showed up...now I have to update the other sites as well.

  11. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    thx for sharing your solution

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic