WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Multi-Site Problem with NGG + possible fix provided (3 posts)

  1. FlipperPA
    Member
    Posted 1 year ago #

    WordPress up to date? Yes.
    NextGEN up to date? Yes.

    MySQL up to date (5.2.4)? 5.0.24a (Ugh, Dreamhost)
    PHP up to date (5.0)? Yep, 5.2.17
    The mod_rewrite Apache module activated? Yes
    PHP Safe Mode OFF? No

    and if you're willing to share:
    Who are you hosted with? Dreamhost
    What theme are you running? Picture Perfect
    Which plugins do you have installed and activated? On this site in multi-site, Google Analytics, Akismet, NGG, All-in-one SEO, Contact Form 7,
    Does this error still occur if you switch your theme to the WP default, and deactivate all plugins except NextGEN Gallery? (*be sure to clear your browser cache and reload your site after deactivating) Yes

    Two problems:
    (1) on the theme we're using, I had to switch "clear: both" to "clear: none" in the CSS class "ngg-galleryoverview" or it pushed the gallery to below the bottom of the initial painted browser screen. Might be an inherited problem from the theme, but the fix works (I can submit these via svn if you like too).
    (2) In multi-site mode, I'm a Network Admin, and have a user who's admin of her own blog, http://www.MakeUpArtistLiz.com ... no matter what I set in multi-site mode, a permissions error occurs which causes the "$hidden_columns" array in manage-images.php to be populated improperly. The user should see all columns, yet the array is populated with all by the checkbox, ID and exclude columns; no captions, thumbnails, or anything are display to the user despite being an administrator on her site. If you do a print_r() or would like a temp account on my site, I'd be happy to show you the solid repro. For now, I just made this change at line 63. This obviously isn't the right fix, but works since we're the only two users on this blog in my multi-site setup:

    $hidden_columns    = array();
    //$hidden_columns  = get_hidden_columns('nggallery-manage-images');

    That just ignores any permissions that should be applied.

    I hope this helps. Feel free to reach out with any questions, and thanks for the great plugin.

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    PHP up to date (5.0)? Yep, 5.2.17

    If you're on Apache, you can go to PHP 5.3, FWIW.

  3. FlipperPA
    Member
    Posted 1 year ago #

    Thanks Mika! I don't think that would solve this problem, but yeah, probably time to upgrade.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic