WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Multi Site not installing (2 posts)

  1. GrahamJBrown
    Member
    Posted 8 months ago #

    I've installed WordPress on some spare hosting at Heart Internet.
    The asks about multi site so have said ok to that and logged in. Tools/Network setup says to add some lines to wp_config

    /**
     *  Change this to true to run multiple blogs on this installation.
     *  Then login as admin and go to Tools -> Network
     */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    
    /* Destination directory for file streaming */
    define('WP_TEMP_DIR', ABSPATH . 'wp-content/');
    
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'softwaregurus.co.uk');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    /* That's all, stop editing! Happy blogging. */

    and to htaccess

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    I still don't get any network menus. Just the network setup which tells me a network has been detected.

    I've asked Heart to look at it as well but a little confused now.
    Any ideas please.
    Cheers
    Graham

  2. GrahamJBrown
    Member
    Posted 8 months ago #

    Just got an email back from Heart tech support to say "Try it now" and everything is working.

    No idea what was failing though.

Reply

You must log in to post.

About this Topic

Tags

No tags yet.