WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce Multilingual - run WooCommerce with WPML
[resolved] Multi currency bug - manually enter prices (15 posts)

  1. mica.merzeau
    Member
    Posted 1 year ago #

    Hello,

    I'm using the development version who is considered best for the better woocommerce and wpml compatibility.
    This fonctionnality is not working. If i set it on "Automatically calculate pricing in different currencies, based on the exchange rate", it works perfectly, but if i choose "I will manage the pricing in each currency myself", there is no way i can manage it. If i go to my translated products and try to change the price, it doesn't save and it stays the same original price from the original product, and the price is always the same for all the currencies... I really need this feature so please answer me :)

    Thanks a lot,

    http://wordpress.org/extend/plugins/woocommerce-multilingual/

  2. mica.merzeau
    Member
    Posted 1 year ago #

    Also even though i can create different delivery classes for each language, in the woocommerce settings i can only select classes from the default language, so they are useless... It's a real probleme for my shop..

  3. bornforphp
    Member
    Posted 1 year ago #

    Dear Mica,

    I have reported this issue to our development team, we will soon release a patch on it.

    I will keep you posted as soon as we release the patch on Manual pricing.

  4. osby
    Member
    Posted 1 year ago #

    Hello!

    I am trying out the new WC 2.0 and everything is working well. But It seems the manual pricing isn't working for anyone.

    The automatic works ok, but honestly I think most people would agree with me that it's better to set the price manually for each currency/language.

    Found this: http://wpml.org/forums/topic/unable-to-update-prices-urgent/ and tried it out, but still no luck.

    Hoping for a fix soon, thank you!

  5. adelval
    Member
    Plugin Contributor

    Posted 1 year ago #

    Hi,

    Sorry for the late reply.

    I answer here only to the first issue you raised, about manual pricing. Basically, the problem is that no fields are saved from translated products unless they are marked as "translate". For this to work, you need to do three things:

    1) In WPML->Translation Management->Multilingual Content Setup, look for the section "Custom fields translation". There, tick "translate" for the fields you want to translate (e.g. all those containing the substring "price").

    2) In WPML->Woocommerce Multilingual, enable multicurrency and select the manual option (Ok, I know you got this right, I put it here just for reference and other readers' benefit)

    3) In each product page, you must do the same thing as in Step 1, such as mark _price, _regular_price and _sale_price as "translate".

    It's clear that the process could be made simpler for users, so I'm reporting back to our development team.

    Please let me know if this works for you. In my test site it did.

  6. David Garcia Watkins
    Member
    Plugin Author

    Posted 1 year ago #

    About the manual setting of prices, try this again with version 1.5 just released. I have tested with WPML 2.7.1 and WooCommerce 1.6.6 and its working correctly so far.

    About the delivery classes, Im not sure I understand. The actual name of the shipping class is not displayed in the frontend, so there is no need to translate it.

  7. rapidz
    Member
    Posted 1 year ago #

    I'm running the latest version of wordpress 3.5.1 and the latest version of WooCommerce 2.0.4.

    I'm using WPML Multilingual CMS 2.7.1
    WPML String Translation 1.6.1

    I can confirm that I also can't manually set the price. I've duplicated a product in the language I want. I then go to edit the page, and enter a different price - but when I update, it doesn't seem to have any effect, the previous price remains.

  8. David Garcia Watkins
    Member
    Plugin Author

    Posted 1 year ago #

    Duplicating a product and manually setting the price of the translation are two things that clash with each other.

    WPML will keep in sync the duplicate and will overwrite your changes to the translation price. For this to work, you need to translate your products independently. You have a big button in each duplicate to unlink it from the original product.

  9. adelval
    Member
    Plugin Contributor

    Posted 1 year ago #

    @rapidz
    Do you also have the latest version of Woocommerce Multilingual (2.0) ?
    The issue about manual conversion of prices did sometimes arise with previous versions, but should be fixed by now. Tested with Woocommerce 2.0.4. (And you don't even need to unlink the duplicate)

  10. rosaiani
    Member
    Posted 9 months ago #

    After I updated to WooCommerce 2.17 Woocomerce MultiLingual doesn't show currencies other than the Main in either language for the site. So my base price is in USD secondary in BRL. Prices in the PT_BR version only shows in USD. Also on WCML settings page there's only one currency showing in the last option, instead of 2.
    Any thoughts?
    Best
    Rodrigo

  11. Amit Kvint
    Member
    Posted 9 months ago #

    @Rodrigo hi,

    I have just checked and on my localhost running WooCommerce 2.17 & Woocomerce MultiLingual 3.0 - both latest versions it all seems to work fine, I have set BRL & USD have made the updates and I can see both currencies according to the language I have set each one for. So my guess would be there is something else that is not working well either with the plugin combinations or maybe some issue in the plugin update process.

    You can try maybe activate WP_DEBUG mode and see if you get any errors related to WooCommerce / WooCommerce Multilingual - http://wpml.org/documentation/support/debugging-wpml/

    If you are using correct latest versions and you don't see any obvious error on log, I'd go to the WPML support forums and see if someone else had the same behaviour - http://wpml.org/forums/forum/english-support/

    Hope that helps.

  12. rosaiani
    Member
    Posted 9 months ago #

    @webifish
    Thanks, I debugged it and there are no errors with multi-lingual.

    It was working ok before the update.
    http://cl.ly/image/033Z400X1L3r Here's a screenshot of the multi currency setup. Only visible language is English. Can this be a clue to the problem?
    Best

    [Moderator Note: Please ensure that you are embedding links correctly in your posts.]

  13. Amit Kvint
    Member
    Posted 9 months ago #

    Hmmm...

    OK you can try WPML->Support-> and then 'Set language information'.

    I think you should take that to one of the dedicated WPML support forums - http://wpml.org/forums/forum/english-support/

    Cheers!

  14. Bas Schuiling
    Member
    Posted 9 months ago #

    Today I stumbled upon the exact same problem while installing although I managed to fix it. The problem is perception I guess.

    - My WP default language was English
    - My Woocommerce Danish with DKK (Krone)

    WooCommerce multilingual settings omit the currency of the primary settings in Woocommerce but also only shows the languages which are not the primary languages of the WP-installation.

    Hence I had a DKK site where I could only add extra currency to Danish language, not the English.

    Solution is to keep this in line. So keep the base currency of the shop aligned with the default language of WPML.

    Hope it's clear like this.

  15. rosaiani
    Member
    Posted 8 months ago #

    Hello Bas, this worked now, perfect.
    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic