WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] MSRP Extension Does not work if W3TC has JS caching enabled (5 posts)

  1. slipperx
    Member
    Posted 1 year ago #

    Hi
    I am running a shop with a number of extensions. MSRP displays a price entered into the product details or variations. I am using it to display a typical shop price. However the extension does not display the price next to the main price or sales price - where I would expect it to show for maximum benefit but rather displays above the order quantity which pops up when you select a variation.

    That is the first problem. I understand some variations may have different prices but that is also true for the main price display - so the function should be to display "MSRP" <price> if all variations have the same price and "MSRP as high as" <highest variation price in product> - the idea of the plugin is to let shoppers see how much they are saving. It makes no sense to hide the information on the page until they have decided to order which is when they will actually select a variation.

    The second problem is that the plugin does not work at all if JS Cache is enabled in W3TC regardless of the settings you select in the JS config. Since W3TC is probably the most widely used caching program a fix is definitely needed for this.

    Incidentally there are instructions on setting up W3TC at this address

    I have already followed those instructions and the extension still fails.

    http://wordpress.org/extend/plugins/woocommerce/

  2. bheadrick
    Member
    Posted 1 year ago #

    this isn't really a wc prolbem as much as a minification problem

    the link you refer to has to do with page caching - not minification.

    You can tell w3tc not to minify on certain pages, but that's not really practical in this case.

    the latest version of w3tc (0.9.2.4) seems to do a much better job at minifying js on auto without breaking anything than the previous version, but it's possible that it could still break the js

    your best bet is probably to put minify in manual mode and add the js files one by one in the order they should load to avoid this issue.

  3. slipperx
    Member
    Posted 1 year ago #

    Bheadrick

    Thanks for that heads up and yes of course it is the JS minification causing the issue and the WooCommerce link is as you say about caching.

    I will take your idea and run with it although I have no clue how to work out the order JS files load or even which files are loading - do I just search through the plugin folders and find all the *.js files or is there a better way?

    Thanks again for the clues to help me move forward.

  4. bheadrick
    Member
    Posted 1 year ago #

    just put them in the same order they show up in the html when minification is turned off.

  5. slipperx
    Member
    Posted 1 year ago #

    I think I managed to fix this by selecting manual minify method and excluding the plugin files. Will update if further issues arise.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic