WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] ms_not_installed() error uploading to Internet (3 posts)

  1. alraul
    Member
    Posted 1 year ago #

    I have a multisite e-commerce wp site. In my localhost is working fine, but when I upload it to Internet a have problems. I found that the site stop in ms-settings.php (inside of wp_includes) in particular in the function:

    ms_not_installed()

    I have an error and the site is not loaded (Error establishing database connection)

    Any help or suggestions?

    Thanks a lot!!!

  2. ricardusexa
    Member
    Posted 1 year ago #

    - First, try contacting the hosting provider if the database server is online / if they have any other problem at their end, or they made any changes to your account, or if there are any limitations/restrictions, if the hosting package is set to Windows and not Linux, etc .

    - double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur.

    -Then check that you don't need to change the database host from "localhost" to something else. You can get that info from your hosting provider.

    -Check you have actually created a database with the same database name as is in your wp-config.php file.
    -Last, but not least, if all that information is correct your database probably has a problem with it, and you may need to contact your hosting provider.

  3. alraul
    Member
    Posted 1 year ago #

    Finally I decided to start again! It is a shame to "lost work" but it is not totally bad, because I learn more about WP.

    Thanks any way!
    Raul

Topic Closed

This topic has been closed to new replies.

About this Topic