WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] mp3 player results in white rectangle (17 posts)

  1. scientist
    Member
    Posted 6 years ago #

    hi all,
    here's a strange problem i need to resolve: i've tried two different mp3 player plug ins, and both have resulted in the same problem on two different sites: instead of the mp3 player graphic showing, there is only a white rectangle where the player should be. started on wordpress 2.0.1 using Audio Player 1.2.3. i've upgraded to wordpress 2.3 and get the same result. it uses the same syntax [audio:xxxx.mp3] as the video player and videos play fine.
    here is one of the sites: http://seaofhands.com with the mp3 syntax in the top post showing up as the white rectangle.
    thanks!

  2. scientist
    Member
    Posted 6 years ago #

    anyone? bueller? bueller? seems like there would be a fix on the wordpress side since i have this problem across 2 version of wordpress, 2 different mp3 plugins and 2 different browsers. maybe i have something in the incorrect directory or something, but not sure. i can upload the mp3s no problem, and a post with a direct download link works, as well as video links with the same syntax (but using a different plug in of course)...

  3. scientist
    Member
    Posted 6 years ago #

    solved this myself: had to move the audio plug in out of its folder and into the plug ins folder (essentially move it up by one in the directory). weird, because other plugs work correctly, and it shows up on the plugin activate/deactivate page in the wordpress interface either way.

    thanks for..well...thanks for nothing!

  4. DanGraves
    Member
    Posted 6 years ago #

    Interesting. I put audio-player.php in the top file to begin with and checked the developers's list to be sure all files were included, but still get just the white rectangle with both audio-player and anarchy media, so I don't know what is up.

  5. scientist
    Member
    Posted 6 years ago #

    the only other possibility i could think of is a conflict with other media players. at the same time i adjusted the plug in directory, i deleted another mp3 plug that had the same white box issue. its possible that it was that plug in that could've been causing the problem. sorry, i know next to nothing about this stuff so this is just a guess. fwiw, i've noticed i'm having problems in firefox with things that work fine in other browsers.

  6. DanGraves
    Member
    Posted 6 years ago #

    Well, it turns out my problem was with Firefox. The white rectangle does not appear in Safari or in Explorer 6. Both play the mp3 just fine.

  7. adamdinger
    Member
    Posted 6 years ago #

    I've tried this in both Firefox and IE and still can't get the audio player to work. I've also tried moving the plugin up one level (out of the audio player folder) and into the parent 'plugins' folder...still no dice, getting that same white rectangle. I've re-uploaded the audio player plugin several times (it's the only one I'm using) and can't seem to get around this issue.

    Any thoughts? I need all the help I can get.

  8. flick
    Member
    Posted 6 years ago #

    Just for the record about scientist's problem: it always helps to read the installation documentation or readme that comes with the plugin when it comes to 'installing' the plugin. Just because many/most plugins work with one folder structure doesn't mean it works for all plugins.

    Any chance of seeing the site at all?

    Your folder structure should look like this:
    http://www.1pixelout.net/code/audio-player-wordpress-plugin/#installation

  9. adamdinger
    Member
    Posted 6 years ago #

    Yeah...

    http://www.audiochicken.com

    I just tried the updated version of the audio player plugin (2.0) and although it's still not working correctly, now I'm getting a message that I need either the latest version of Adobe Flash Player or to have JavaScript enabled in order to listen...both of which I have. Still nothing.

    Thanks!

  10. adamdinger
    Member
    Posted 6 years ago #

    I'm actually getting this when I go to the audio player plugin settings...

    Warning: AudioPlayer::include(/home/dinger78/public_html/blog/wp-content/plugins/audioplayer/php/options-panel.php) [audioplayer.include]: failed to open stream: No such file or directory in /home/dinger78/public_html/blog/wp-content/plugins/audioplayer/audio-player.php on line 532

    Warning: AudioPlayer::include() [function.include]: Failed opening '/home/dinger78/public_html/blog/wp-content/plugins/audioplayer/php/options-panel.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/dinger78/public_html/blog/wp-content/plugins/audioplayer/audio-player.php on line 532

    So I deleted and re-uploaded the 'options-panel.php' file and it's still showing the same message.

  11. flick
    Member
    Posted 6 years ago #

    The key thing here is that your folder name is not right.
    It should be audio-player rather than audioplayer. This applies to both the 1.2.3 version and the latest 2.0 beta :)

  12. adamdinger
    Member
    Posted 6 years ago #

    Hmmmm...I changed the folder name but I'm still getting the same Flash/JavaScript message, as well as the same error message in the plugin settings menu.

  13. flick
    Member
    Posted 6 years ago #

    How are you uploading the files? It's still not complete.

    Normally I find it's pretty safe to unzip the files onto my hard drive first, then upload the entire "audio-player" folder. This helps to retain the folder structure.

  14. adamdinger
    Member
    Posted 6 years ago #

    I'm basically pushing them into the 'audio-player' folder in my 'plugins' folder through the file manager, one at a time. The file manager is asking for individual files so I don't know how to upload the entire folder all at once (I can't select all from the hard drive to batch upload). Do you us the FTP or the cpanel file manager?

    Thanks for all your help, by the way.

  15. flick
    Member
    Posted 6 years ago #

    I use FTP and would highly recommend using it in place of a file manager - it's painful uploading one file at a time, and quite easy to mess up the folder structure as a result (I'm currently using Filezilla, although I personally prefer SmartFTP)

    What the error is showing you is that there is no file called 'options-panel.php' in your /audio-player/php/ folder. When I last checked your plugins folder, there was no /php/ folder in /audio-player/, so it's not a surprise that options-panel.php could not be found there.

    For your reference: http://www.wpaudioplayer.com/installation, this is the most up-to-date folder structure for the beta 2.0 version of the audio player.

    Hope this is helpful.

  16. adamdinger
    Member
    Posted 6 years ago #

    Got it! Thanks for all your help! FTP maintained the file structure, which did the trick.

  17. flick
    Member
    Posted 6 years ago #

    You're welcome. Glad to hear it's resolved!

Topic Closed

This topic has been closed to new replies.

About this Topic