WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Moving WP to Host: Error Establishing a Database Connection (5 posts)

  1. IronMac
    Member
    Posted 7 years ago #

    Hi everyone,

    Everything looked like it was going pretty well and now I've hit this problem. I seem to have transferred everything over properly to my new domain http://www.steppingforth.com from where my blog was hosted at http://ironmac.blogdns.com/blog which is on my own Mac.

    Problem begins when I hit the Login button on my blog and it points me to http://ironmac.blogdns.com/blog/wp-login.php. There it gives me the "Error Establishing a Database Connection" message. In fact, hitting any of the links on the site gives me that error. I've asked my host (A Small Orange) for assist but the best they can give me now is:

    "That url could be in the database itself, I didn't see any reference to it in the files. You'll need to use phpMyAdmin to edit the url directly in the database."

    Which is way over my head...

    Any assist would be greatly appreciated...thanks! :)

  2. Chris_K
    Member
    Posted 7 years ago #

    For future reference, next time look over Moving_WordPress before starting.

    For current reference, you'll want to update the URI values in the database to properly point to the new location. The manual/"oops-I-Broke-it-Method" can be found in this little tutorial: http://www.tamba2.org.uk/wordpress/site-url/

    On a final note: If you make a post here and it doesn't show up right away, just patiently wait for a moderator to release it from the spam traps instead of loading the traps up with 6 more copies ;-) Thanks!

  3. IronMac
    Member
    Posted 7 years ago #

    I'm sorry about that! Thought that I wasn't being allowed to post for some reason. I'll give the URI values a check. Thanks!

  4. IronMac
    Member
    Posted 7 years ago #

    Heyyyy!!! I got it done!!! Thanks HandySolo!

    I did follow the Moving_WordPress in the Codex but the URI values in the database was where I went totally wrong! Didn't even know about that... :(

    Onwards and upwards now! :)

  5. Chris_K
    Member
    Posted 7 years ago #

    Awesome, glad to hear it. Happy blogging!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.