WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Moving WordPress 3.1 to new server, changing config causes blank sites (7 posts)

  1. snapoint
    Member
    Posted 3 years ago #

    Okay I moved two wordpress sites to a new server. I uploaded both on the new server using a fresh download. Then I added my theme and plugins in those directories.
    I imported the databases in phpmyadmin. Then when I change the config files from previous installs to have the correct database host and upload them, I just get blank pages over both sites.

    I removed the config files on both and get a message that says:

    There doesn't seem to be a wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file.
    When I click Create a Configuration File (I was going to create a new one and then change the info) I get this:
    The requested URL /wp-admin/setup-config.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    The sites are at virtuallylegal.net and snapoint.org
    I currently have removed the config files and left them at the screens asking for one.
    Thanks, this is making me crazy!

  2. Tara
    Member
    Posted 3 years ago #

    I moved two wordpress sites to a new server. I uploaded both on the new server using a fresh download.

    fresh downlosd of of version 3.1?

    Then I added my theme and plugins in those directories.
    I imported the databases in phpmyadmin.

    databases also from version 3.1?

    The reason I asked is that the database structure often changes between versions. As a result, one cannot import a pre 3x database into a 3x install and expect it to work.

  3. snapoint
    Member
    Posted 3 years ago #

    Yes, and yes.

  4. Tara
    Member
    Posted 3 years ago #

    did you follow instructions of this codex guide: http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_to_a_New_Server

  5. snapoint
    Member
    Posted 3 years ago #

    Yes I did. I've moved one of these sites successfully before. I'm starting to wonder if the new server configuration is somehow an issue. I'm moving from shared hosting to a VPS account and I may have something not set up right.
    Could this be possible?

  6. Tara
    Member
    Posted 3 years ago #

    It wouldn't hurt to discuss the issue with your hosting provider

  7. arkgroup
    Member
    Posted 3 years ago #

    snapoint,

    Issue could be fixed in minutes. Probable cause:
    1. Wrong info in wp-config.php files.
    2. Some files were damaged during the move.

Topic Closed

This topic has been closed to new replies.

About this Topic