WordPress.org

Ready to get started?Download WordPress

Forums

Moving to SSL page with https (3 posts)

  1. emptymind
    Member
    Posted 5 years ago #

    Currently my site is http://emptymindfilms.com and my host set up a SSL but this is at https://secure.emptymindfilms.com
    I am trying to get the checkout page, http://emptymindfilms.com/checkout to now be https://secure.emptymindfilms.com/checkout. I am running wp ecommerce plugin.

    The only solution is to set the entire site as https which is what my host company did, but I do not want this solution. I tried the admin SSL plugin but this is not working with wp2.8 and I could not even test to see if this would be a possible answer anyway.
    Is there some way to redirect my checkout page on to the secure page and then all links will go back to the http site?
    Thank you users.

  2. jeremysawesome
    Member
    Posted 4 years ago #

    Steps to solve your issue (from memory).

    1. Set your checkout page in the WP-Ecommerce Plugin options to the https page you want.
    2. Install HTTPS for WordPress plugin and activate.
    3. Check your checkout page - it should redirect properly now.

    You may have to run through the source of the checkout page to find files that aren't sent over HTTPS (usually these are related to plugins). These files do not get filtered by HTTPS for WordPress and can sometimes cause the "viewing non-secure and secure items" error.

  3. mcrib
    Member
    Posted 4 years ago #

    emptymind - I have the same problem. Did this solution work for you? I tried it and it isn't working for me. I took a look at your website and saw that you got it fixed. Please tell me how you did it. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags