WordPress.org

Ready to get started?Download WordPress

Forums

Moving to new hosting (9 posts)

  1. semadvance
    Member
    Posted 9 years ago #

    Hi there

    I looked through the forum pages but could not find this topic covered.

    I started a blog about a month ago and googlebot found it in a few days. After signing up with godaddy I found I can't run many other 3rd party scripts and want to move my blog to a new hosting account I set up.

    What is the best procedure to do this with the least amount of problems??

    Thank you for your help.

    Clint
    http://www.sem-surgeon.com

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    There are many many many posts on moving your blog - I know, I've answered them. And there is also a Codex page:
    http://codex.wordpress.org/Moving_to_a_new_server

  3. Jennifer Ledbetter Clay
    Member
    Posted 9 years ago #

    http://www.tamba2.org.uk/wordpress/

    Podz has great wordpress guides. I'm sure these will be able to help you :)

  4. semadvance
    Member
    Posted 9 years ago #

    Hmmmm perhaps I should have tried the search feature eh?

    Bonks head on desk...

    Danke

    Thank you

    Gracias

    Clint

  5. djsebo
    Member
    Posted 7 years ago #

    tamba2 gives nice description but it is still not working for me :]

    So what I did:
    1. I made copy of database and wordpress folder.
    In my case address was hostname.com/wordpress
    2. I put wordpress folder on new new host.
    In this case adress is newhost.com/wordpress
    3. I went to database config and copied all lines from backup file.
    4. I've changed wp-config.php and gave all rights.
    5. I went to see website on new host and what I saw was my website without polish letters and few warning lines as this below:

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(../../../../a8e424dc09dae7c05417.txt) is not within the allowed path(s): (/home/site:/home/www:/usr/share/php) in /home/site/14927/www/wordpress/lpa8e424dc09dae7c05417.php on line 57

    I believe that I didn't get polish letters because of wrong encoding in TextEditor which I used to copy database instructions but what the hell is this warning !?
    Next thing is that when I go to admin panel I don't see any tabs!
    What is more I have to put login address manually because wp still shows address to my previous host.

    I tried two different ways:
    -with changing address in admin options before I made backup
    -and without changing address in admin options

    Well I am out of ideas and totally exhausted.
    Please help me.

  6. vkaryl
    Member
    Posted 7 years ago #

    Your info in the wp-config.php file on the new host is quite likely not the same as on the old host. Check that first to be sure you have everything right.

    The open_basedir restriction warning is odd. Once you have the wp-config.php settings correct, if it still appears, then you need to talk to your host.

  7. djsebo
    Member
    Posted 7 years ago #

    this is my old file:

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'old_dbname'); // The name of the database
    define('DB_USER', 'old_dbuser'); // Your MySQL username
    define('DB_PASSWORD', 'old_pass'); // ...and password
    define('DB_HOST', 'dbserveraddress'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp2_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', 'pl_PL');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    ---
    and this is my new one:

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'new_dbname'); // The name of the database
    define('DB_USER', 'new_dbuser'); // Your MySQL username
    define('DB_PASSWORD', 'new_pass'); // ...and password
    define('DB_HOST', 'now-it-is-localhost'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp2_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', 'pl_PL');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    ------

    This is address to new host with WP:
    http://www.grafer.prothost.pl/wordpress/

    Old one is here:
    http://www.grafer.webpages.pl/wordpress/

    Even address is similar!

  8. djsebo
    Member
    Posted 7 years ago #

    I have changed address in database by text editor and WP is running. I still have this error massage below footer and I don't have good encoding but that's not a case.

    The problem is that when I log in as admin I receive massage - You don't have privileges to see this site.

    How it is possible ?

  9. Reaper-X
    Member
    Posted 7 years ago #

    Ask your webhosting provider to disable open_basedir restriction

Topic Closed

This topic has been closed to new replies.

About this Topic