WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Moving to a new host (18 posts)

  1. mndoci
    Member
    Posted 7 years ago #

    I know this has been posted often, so please forgive yet another post on this subject. I have a blog hosted at Yahoo, but am moving it to A Small Orange where I have a couple of other sites I am setting up. The site will be set up there as an add-on domain.

    I followed the instructions from Podz' site. Backed up my database, copied all the blog files into the appropriate folder. Created a new database there and imported the database into that (using phpmyadmin). The database name is different from what I can gather. It was 'blog' at Yahoo and XYZ_blog at ASO. I changed that in wp-config.php.

    However when I log into abcd.net/XYZ/ where XYZ is the folder in which I put all my blog files I get the dreaded message

    "This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at mysql. This could mean your host's database server is down."

    Any help would be much appreciated. I will be pointing my DNS servers to the new site when it is up and running.

  2. DianeV
    Member
    Posted 7 years ago #

    First thing to check are whether the username and password are the same (not just the database name)? If not, change them.

    Also, whether you must now reference your database host (DB_HOST) in config.php as "localhost" or your domain name or something else.

    If your blog is *now* in a folder, that may need to be changed in the database files (through phpmyadmin).

    The other thing is that setting up the site as an add-on domain --- to what? to a main domain? Or just as an additional web hosting account? These may factor in to how you must reference the database.

  3. mndoci
    Member
    Posted 7 years ago #

    Diane

    Thanks for your response. Very good question. Here's how it works. I have moved one domain over (not a blog) already, and things seems easy enough.

    1. All files go into a folder called public_html. The main domain resolves to that folder. Each addon domain goes into its own folder underneath public_html. In the previous case, changing the DNS to point to my new hosts DNS servers did the trick

    2. In my current blog I have the following structure
    /
    index.php
    blog/

    All my files are under blog, but going to xyz.com reads the index.php file which just points to the blog/ (something I would love to change but too much content to take the risk now)

    3. The database part is what I am worried about. I am no MySQL guru. Are the username and password in wp-config.php the same as the admin username and password for my wordpress account? They are a random string in wp-config.php. I presume I can use regular text to change things?

    Thanks for all the help

  4. mndoci
    Member
    Posted 7 years ago #

    I redid everything from scratch and still the same problem

    Here is my wp-config.php. Everything is the same as before, except that here the db name and username have a pre-fix that cpanel automatically attaches when I created the empty db and a new user for it. I typed in the username and password manually into the file (probably not the right thing to do either)


    <?php
    define('WP_CACHE', true); //Added by WP-Cache Manager
    // ** MySQL settings ** //
    define('DB_NAME', 'blog_db_name'); // The name of the database.
    define('DB_USER', 'username'); // Your MySQL username
    define('DB_PASSWORD', 'password'); // ...and password
    define('DB_HOST', 'mysql'); // 99% chance you won't need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    /* Stop editing */
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

  5. mndoci
    Member
    Posted 7 years ago #

    From what I can gather, the addon domain is not an issue. Since I am not changing the blog structure, I suspect its the database. Any troubleshooting suggestions?

  6. moshu
    Member
    Posted 7 years ago #

    define('DB_HOST', 'mysql'); - if it is NOT the usual "localhost"... very unlikely to be the same on two different servers/host!

  7. mndoci
    Member
    Posted 7 years ago #

    Thanks, that seemed to help... and changed the errors

    Now I am getting a bunch of cache related errors like the following


    Warning: fopen(/home/user/public_html/domain_name/blog/wp-content/cache/wp_cache_mutex.lock) [function.fopen]: failed to open stream: No such file or directory in /home/user/public_html/domain_name/blog/wp-content/plugins/wp-cache/wp-cache-phase2.php on line 79
    Couldn't write to: /home/user/public_html/domain_name/blog/wp-content/cache/wp-cache-48736852343c354627f7d006c54befd0.html

  8. jamin100
    Member
    Posted 7 years ago #

    1. Do you use WP-Cache plugin?
    2. Did you copy all your plugins and theme's over?

  9. mndoci
    Member
    Posted 7 years ago #

    1. Yes I do
    2. Not all my themes, since there were a few I never used. I guess I should. Plugins, yes. I had not copied the content of the cache folder (under wp-content), but I just did. However, the specific file that is giving the error is not there.

  10. mndoci
    Member
    Posted 7 years ago #

    Just for the record here is the complete error message


    Warning: fopen(/home/user/public_html/domain_name/blog/wp-content/cache/wp_cache_mutex.lock) [function.fopen]: failed to open stream: Permission denied in /home/user/public_html/domain_name/blog/wp-content/plugins/wp-cache/wp-cache-phase2.php on line 79
    Couldn't write to: /home/user/public_html/domain_name/blog/wp-content/cache/wp-cache-48736852343c354627f7d006c54befd0.html
    Warning: flock(): supplied argument is not a valid stream resource in /home/user/public_html/domain_name/blog/wp-content/plugins/wp-cache/wp-cache-phase2.php on line 88
    Warning: fopen(/home/user/public_html/domain_name/blog/wp-content/cache/wp-cache-48736852343c354627f7d006c54befd0.meta) [function.fopen]: failed to open stream: Permission denied in /home/user/public_html/domain_name/blog/wp-content/plugins/wp-cache/wp-cache-phase2.php on line 223
    Warning: fputs(): supplied argument is not a valid stream resource in /home/user/public_html/domain_name/blog/wp-content/plugins/wp-cache/wp-cache-phase2.php on line 224
    Warning: fclose(): supplied argument is not a valid stream resource in /home/user/public_html/domain_name/blog/wp-content/plugins/wp-cache/wp-cache-phase2.php on line 225
    Warning: flock(): supplied argument is not a valid stream resource in /home/user/public_html/domain_name/blog/wp-content/plugins/wp-cache/wp-cache-phase2.php on line 97

  11. mndoci
    Member
    Posted 7 years ago #

    BUMP .. Anyone?

  12. mndoci
    Member
    Posted 7 years ago #

    An update:

    I redid the blog move, this time, turning off a few plugins, including wp-cache. I changed my nameservers over. The front page looks OK, but when I click on individual links, I am getting errors like

    The requested URL /blog/archives/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    What could be causing this?

    Thanks

  13. Chris_K
    Member
    Posted 7 years ago #

    Check out troubleshooting tips at the Permalinks page.

    New move? make sure you've been to that page and re-saved your current settings.

    Didn't improve? Confirm with host that mod_rewrite and AllowOverrides are on and properly enabled.

  14. mndoci
    Member
    Posted 7 years ago #

    A number of people have successfully moved to my current host, so I suspect it does work, and Podz (whose tutorial I followed) also hosts there.

    I did create a .htaccess file. Lets see how it works.

    I am not sure what you mean by the re-saving settings part? Yes, this is a completely new host (same domain name).

  15. Chris_K
    Member
    Posted 7 years ago #

    I am not sure what you mean by the re-saving settings part?

    Options -> Permalinks

    Click "Update Permalink Structure"

  16. mndoci
    Member
    Posted 7 years ago #

    Thanks

    Some more messages that I am seeing.

    On the Permalinks Options page, I see the following at the top of the page

    Warning: unlink(/XYZ/blog/.htaccess) [function.unlink]: Permission denied in /XYZ/blog/wp-content/plugins/yplink.php on line 41

    Also when I try and turn off the customize permalinks plugin (and then on again, I see the following

    Warning: touch() [function.touch]: Unable to create file /XYZ/blog/.plink because Permission denied in /XYZ/blog/wp-content/plugins/ywhservices.php on line 182

    Warning: touch() [function.touch]: Unable to create file /XYZ/blog/.plink because Permission denied in /XYZ/blog/wp-content/plugins/ywhservices.php on line 182

    Warning: Cannot modify header information - headers already sent by (output started at /XYZ/blog/wp-content/plugins/ywhservices.php:182) in /XYZ/blog/wp-admin/plugins.php on line 16

  17. Chris_K
    Member
    Posted 7 years ago #

    The blog is no longer at Y!, right? Do you still have all the Yahoo specific plugins enabled?

  18. mndoci
    Member
    Posted 7 years ago #

    Handy

    Killing the Yahoo specific plugins seemed to have done the trick. I still have some issues (probably permission related), but at least the blog is running now.

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic