WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Moving Sites: Database Query (Japanese characters) (3 posts)

  1. Keilya
    Member
    Posted 8 years ago #

    Okays...I do understand how to actually export and import the tables. The thing is, I've inputted some of my titles and posts in Japanese. And when I export them, they turn into characters like these: %e3%83%af%e3%83%ab

    Will they revert back to the Japanese words when I import them to another server?

    If not, what can I do to prevent them from turning into these characters? x.x

    Help most appreciated!

  2. dutch_gecko
    Member
    Posted 8 years ago #

    I've just found this thread, which at first doesn't look too promising. After a quick bit of research though, it looks like there are a few types of character encoding.
    In theory, if you use the same character encoding on your new site as on your current one, all should turn out fine. If it doesn't, you may have to do some tweaking, by using XHTML's ability to set language and character encoding for individual tags.
    My best guess for accomplishing this would be to use the Gengo plugin, making sure to set a character set for those posts in Japanese. You can read up on how to do this over here.

  3. Keilya
    Member
    Posted 8 years ago #

    Thanks a lot dutch_gecko! I'll check back here when I move servers in June! ^_^ You've been a great help!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags