WordPress.org

Ready to get started?Download WordPress

Forums

Moving site from localhost (8 posts)

  1. alfiepanda
    Member
    Posted 2 years ago #

    Hello
    I developed my site on localhost. I was about to upload it to my isp and was changing the field on the Settings - General page to point to the new url. My site has a "-" between 2 words as in "sales-source". However when I clicked to go, the "-" had not been recognised or acknowledged( or I hadn't put it in!) and I got back a SEDO page advising me that the site "salessource" could be bought for $1599. Now I don't want to do this of course.
    Now I find I cannot get back to my site whatever I do- the back button stays on this SEDO page.I cannot access the admin page as it goes to this SEDO page. So I'm stuck! HELP please welcome. Presumably there's a file somewhere with the details in that needs to be edited.
    Thanks

  2. Now I find I cannot get back to my site whatever I do

    You've changed your site URL and want to change it back to a correct DNS name. Give this a read.

    http://codex.wordpress.org/Changing_The_Site_URL

    Personally I prefer adding two lines to the the functions.php file myself.

    codex.wordpress.org/Changing_The_Site_URL#Edit_functions.php

  3. alfiepanda
    Member
    Posted 2 years ago #

    Hello Jan
    Thanks for the quick response. I've followed the article instructions by editing the wp-config.php file and adding define('RELOCATE',true);
    I then put in http://salessource/wp-login.php and indeed did get a login screen-without the template. I entered the login details as normal but STILL get this SEDO screen!

    I am on localhost so the site can't have gone anywhere but the name I am using "salessource" is what this SEDO site is bringing back and asking me to buy. I don't think I can ftp localhost or access via phpmyadmin so any more ideas welcome.
    Thanks

  4. It's a name resolution problem I think. The styling is attempting to load via the SEDO site and not localhost.

    Try one of those methods in the Codex article to change your WordPress and site URL to localhost. That ought to fix it and let you in.

  5. alfiepanda
    Member
    Posted 2 years ago #

    Hello again
    Well I hardcoded the url http://127.0.0.1/wp-salessource into both locations and get exactly the same result as before - it goes straight to this SEDO site. if I add the /wp-login.php it allows me to log in but goes straight to this SEDO site still. Same happens if I click "register" rather than log in. So more confused.!
    regards
    Tony

  6. Have you cleared your cache on your proxy? 127.0.0.1 should not ever go elsewhere...

  7. alfiepanda
    Member
    Posted 2 years ago #

    Hello again

    FYI I found a rogue/ that I had left and retried everything. After the 3rd attempt it suddenly burst into life! both the local site and the admin. I checked the settings -General tab and the 2 url boxes are now greyed out. So.....I now want to move the site to my host which is http://sales-source.co.uk. Do I leave the first WP address as it is and hardcode the config.php file with the new url in the 2nd field? or do you have a better idea?
    Thanks
    Tony

  8. I checked the settings -General tab and the 2 url boxes are now greyed out.

    ...

    Do I leave the first WP address as it is and hardcode the config.php file with the new url in the 2nd field? or do you have a better idea?

    Keep the two values the same. As long as the DNS works, it should be fine.

    When you hard code the option in wp-config.php this way

    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

    It greys out those fields because the override wins over the GUI.

    It's why I prefer this method myself:

    http://codex.wordpress.org/Changing_The_Site_URL#Edit_functions.php

    It updates the option for you in your theme's functions.php file

    update_option('siteurl','http://example.com');
    update_option('home','http://example.com');

    It actually updates the database for you. Once that's done you can remove those two lines and continue working with your blog.

Topic Closed

This topic has been closed to new replies.

About this Topic