WordPress.org

Ready to get started?Download WordPress

Forums

Moving Problem (5 posts)

  1. hoanglong
    Member
    Posted 7 years ago #

    Well i just moved all my wordpress files, folders and database to a new host+domain, i changed the config file, and few database query to update ot my new domain.

    the only error i get is when i try to write, the picture upload section below the text box has this error

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/home/atomicb/public_html/l/wp-content/uploads/2006/12/yahootvlogo.thumbnail.jpg) is not within the allowed path(s): (/home/lonesoul:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/lonesoul/public_html/wp-admin/inline-uploading.php on line 226

    there are 4 of the same error

    my old host path was /home/atomicb/ and my new host path is /home/lonesoul/

    i search the SQL and couldnt find any path that i need to update? any ideas?

    thanks

  2. drmike
    Member
    Posted 7 years ago #

    open_basedir restriction in effect.

    That's your issue right there. Check with your host. They have additional security measures in place.

  3. Samuel B
    moderator
    Posted 7 years ago #

    That's a host deal. Basically this error indicates that your host has enabled the PHP open_base_dir setting on your server. Your host needs to add your WP installation folder to the allowed paths for this setting (i.e., add the file path referenced in the error as "not within the allowed path").

    The open_base_dir setting is primarily used to prevent php scripts for a particular user from accessing files in another user's account. So usually, any files in your own account should be readable by your own scripts.

    Check this out:
    http://us2.php.net/features.safe-mode
    If you have a php.ini you can do it yourself.

  4. rottie_lover
    Member
    Posted 6 years ago #

    Thank you so much for this information. I contacted my host with the error message info and their tweaks eliminated the error message.
    Suzanne

  5. fra73
    Member
    Posted 6 years ago #

    hi,
    i'm experiencing the same problem...i looked at the php.ini file but the opendir setting is ok (it is commented..i can actually import images on another blog wich reside in the same server...so it is not about php config)....safe mode are off.....I have also changed the images path to the new address in the posts.sql table but nothing changes....can u please help me?

    Francesco

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags