WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Moving images between galleries is sssllloooooowwww (8 posts)

  1. oliviercaro
    Member
    Posted 1 year ago #

    Hello,

    Everything is in the title: When I move 10 images from one gallery to another, it may take 30mn or more.

    The database holds around 380.000 images but the tables are properly optimized and each MySQL query such as:
    SELECT image_slug FROM wp****_ngg_pictures WHERE image_slug = 'image-961' AND NOT pid = 0 LIMIT 1
    takes up to 10 seconds to run.

    Any idea?

    Thxs for help

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @oliviercaro - You might try increasing the memory_allowed in your php.ini file. Also, if you're on a shared server, it's likely that your hosting account is being throttled which will cause functionality to run slower than normal. So you may want to contact your server host tech support and have them check the CPU throttling on your account and error reports.

    Hope that helps!
    -Becky

  3. oliviercaro
    Member
    Posted 1 year ago #

    @Becky

    in /etc/php5/apache2/php.ini
    memory_limit = 256M

    Should I use more? (16GB on the server)

  4. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @oliviercaro - That should be plenty of memory. What does your hosting provider say about the CPU throttling and error report?

  5. oliviercaro
    Member
    Posted 1 year ago #

    My blog/gallery is hosted on a dedicated server (ubuntu 13.04 64bit) so I can tweak whatever I want, based on your advice, if you please :)

  6. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    Hmmm, I'm not too familiar with Ubuntu, but here are the requirements that our plugin needs from the server:

    - PHP version 5.2.4 or greater
    - MySQL version 5.0 or greater
    - The mod_rewrite Apache module

    - PHP Safe Mode turned OFF
    - At least 128MB memory allowed (250MB is ideal)
    - 10MB upload limit

    - 755 permissions set on /wp-content directory. If your hosting environment requires higher than 755, you risk being vulnerable to hackers. This is a sign of a less supportive web host for WordPress. You should NEVER have to go as high as 777
    - GD Library enabled and activated on your hosting account

    Hope that helps!
    --Becky

  7. oliviercaro
    Member
    Posted 1 year ago #

    Hello,

    Here is what phpinfo gives:

    PHP Version 5.3.10-1ubuntu3.6
    mysql Client API version 	5.5.31
    Loaded Modules 	core mod_log_config mod_logio prefork http_core mod_so mod_alias mod_auth_basic mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_deflate mod_dir mod_env mod_mime mod_negotiation mod_php5 mod_reqtimeout mod_rewrite mod_setenvif mod_status 
    
    safe_mode off
    
    memory_limit	1024M
    upload_max_filesize	20M
    
    permissions are OK:
    
    -rw-r--r-- 1 www-data www-data   395 janv.  8  2012 index.php
    -rw-r--r-- 1 www-data www-data 19929 mai    6  2012 license.txt
    -rw-r--r-- 1 www-data www-data 11200 janv. 25 01:31 readme.html
    -rw-r--r-- 1 www-data www-data  4663 nov.  17  2012 wp-activate.php
    drwxr-xr-x 9 www-data www-data  4096 janv. 25 01:31 wp-admin/
    -rw-r--r-- 1 www-data www-data   271 janv.  8  2012 wp-blog-header.php
    -rw-r--r-- 1 www-data www-data  3522 avril 10  2012 wp-comments-post.php
    -r--r--r-- 1 www-data www-data  4059 juin   5 00:50 wp-config.php
    -rw-r--r-- 1 www-data www-data  3823 janv. 25 01:31 wp-config-sample.php
    drwxr-xr-x 9 www-data www-data  4096 juin  16 01:38 wp-content/
    -rw-r--r-- 1 www-data www-data  2718 sept. 23  2012 wp-cron.php
    drwxr-xr-x 9 www-data www-data  4096 janv. 25 01:31 wp-includes/
    -rw-r--r-- 1 www-data www-data  1997 oct.  23  2010 wp-links-opml.php
    -rw-r--r-- 1 www-data www-data  2408 oct.  26  2012 wp-load.php
    -rw-r--r-- 1 www-data www-data 29310 nov.  30  2012 wp-login.php
    -rw-r--r-- 1 www-data www-data  7723 sept. 25  2012 wp-mail.php
    -rw-r--r-- 1 www-data www-data  9899 nov.  22  2012 wp-settings.php
    -rw-r--r-- 1 www-data www-data 18219 sept. 11  2012 wp-signup.php
    -rw-r--r-- 1 www-data www-data  3700 janv.  8  2012 wp-trackback.php
    -rw-r--r-- 1 www-data www-data  2719 sept. 11  2012 xmlrpc.php
    
    GD Support 	enabled
    GD Version 	2.0
  8. philhagen
    Member
    Posted 1 year ago #

    Seeing the same thing on all 2.0.x versions including 2.0.11. Thousands of these queries per page:

    SELECT image_slug FROM xxx_ngg_pictures WHERE image_slug = 'image-443' AND NOT pid = 0 LIMIT 1

    Each page takes several tens of seconds per load, and sites with a larger number of photos take significantly longer.

    This only appears to happen with galleries created *after* the upgrade, however. Galleries created prior to v2.0 still load fine. This is happening consistently on multiple sites running the plugin.

    Reverting to 1.9.13 fixes this problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic